Composite Video: How to change from 4:3 to 16:9?

  • I would like to use RasPI with LibreELEC and KODI in my car, having a 16:9 screen with only composite input.
    I've set up the Raspberry PI 3 Model B with current LibreELEC and KODI, and bought a composite cable.


    But when using it, I see only a 4:3 "square" is filled on the screen, not the whole 16:9 screen. Black areas are remaining on left and right side.
    I have the same 4:3 result, if I attach it to my 16:9 flatscreen television at home via composite. (HDMI works fine there in 16:9, but I don't have HDMI in the car.)


    I tried to move the corners in the KODI video settings to adapt the picture. This works, to set the picture size exactly to the visible 4:3 field. But if I move the corners into the black areas at both sides, the corners disappear behind the black. :-(


    I've read instructions for other OS, to set in config.txt:
    sdtv_aspect=3 # 16:9
    sdtv_mode=2 # PAL for Europe
    I've tried this configuration values in LibreELEC, but unfortunately it did not change anything, the issue is still the same.


    What can I do, to use the full 16:9 screen using composite video signal? Thanks for any hint!

  • Really not sure if this is of use.
    From Settings > system> Display - over to Resolution and toggle?
    I see you have tried the calibration option.

  • Usually you have manually switch the screen to 16:9/anamorphic mode. Check the manual of your screen if there's some setting in a menu, a switch or something like that.


    Automatic switching to anamorphic mode in (PAL) TVs relies on information transmitted in the video signal during vertical blank (or in one of the cut-off overscan lines, can't remember) but AFAIK RPi doesn't generate these signals.


    I'm using my RPi 3 on a 16:9 CRT TV, connected via composite, and had to manually put my TV into anamorphic 16:9 mode as well.


    so long,


    Hias