No SSH Access

  • Hey all,

    My no SSH access is solved ! But not in the manner I wanted... ;(

    My old and friendly Wetek Play 2 isn't anymore. I do not know what happened, but it full crashed, impossible to boot. I think I had some electrical issue or something. none of the LED are blinking when I plug the DC adapter.

    Nontheless now it's time to find a new board where I can install a TVHeadend PVR. I only have the possibility to get DVB-T (DVB-T2) TV signal, so condition number one is finding a box with a tuner built in (like my old WP2).

    I think I find out the right one. I see that the "formuler cc" seems to be a goo challenger (

    Seems that he as an ARM A-53 CPU. so I do think it is a SOC S905 and that I could use the LibreELEC-AMLGX.arm-11.0.3-box image to root it.

    I think that I am not in the right topic to ask this and if not, feel free to signal or migrate to a new post.

    And otherwise, have you guys any suggestion for an LibreElec ready box with built in DVB tuner ?



  • Seems that it has ARM A53 CPU so I think it is a SOC S905 and that I could use the LibreELEC-AMLGX.arm-11.0.3-box image to root it.

    If you scroll down the page far enough it shows "CPU: Hisilicon Quad-core" which means it's not Amlogic and we currently have zero support for any HiSilicon chips (all their chips require horrid vendor kernels, nothing upstream).

  • all their chips require horrid vendor kernels, nothing upstream

    Hi Chewitt, you always answer :)

    That's what I unfortunately thought... Maybe I'm to lazy to check everything in details, but what make me say that it would be a possible candidate was when I google (duckduckgo'ed more precisely) : "Hisilicon Quad-core" the first result I found that link :…STB/Hi3798MV200 where it says : blablabla hanks to the powerful Arm Cortex-A53 blablabla

    I'm not so good in hardware stuff but Amlogic is different from ARM chip ? (I know this is a noob question).

    I tried to figure that out myself and read a couple of articles and something in Wikipedia makes me wonder that I might have found what I need. In the chart where you can find ARM and I thought bingo !

    And finally I reread it this evening and saw that, indeed, Hisilicom seems to only buy the architecture licence from ARM and design his own chip... DAMMMIT (language please, would say Tony Stark ^^)

    Back to the start... I need to find something who has the ability to run TVHeadend with a DVB-T2 tuner.... Why.. but why didn't Wetek exist anymore ...

  • Have a look at HDHomeRun boxes for a 'Network' tuner device. Then use something else as the client/player device. In the long term you can update the client as needed for latest features while the tuner remains the same. It avoids lots of kernel/driver matching complexity which is often a challenge due to the state of DVB drivers in the kernel.

  • Thanks Chewitt.

    I checked, but unfortunately... HDhomeRun doesn't sell any DVB-T boxes anymore. Or maybe I did not search properly... seems that ran out of component :P

    Meanwhile, I'll give a try to a USB Hauppage DBT stick which I will connect to my PVE NUC. Already installed the soft TVHeadEnd and now waiting for the delivery of the stick. I just hope that I will not hardness with the ubuntu configuration (finger deeply crossed)

    Thanks thanks again