Adjust refresh rate setting with Amlogic?

  • Using Kszaq's builds 8.0.1e - 8.0.1h I find it necessary to turn off the Adjust display refresh rate option in Kodi settings. In previous builds I set it to Always or Start/Stop. With the setting on in these builds I have long delays switching channels, random crashing on video start, etc.


    I guess the question is, should LE be doing the refresh rate switching even with the option turned off? It certainly seems to be, at least according to what is reported in Codec Info. I guess I don't have a good grasp as to what the option is actually supposed to do.

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME


  • I guess the question is, should LE be doing the refresh rate switching even with the option turned off? It certainly seems to be, at least according to what is reported in Codec Info.


    Refresh rate switching to your TV is what it does.
    Check if your TV refresh rate changes when it is enabled and vice versa.
    Codec info displays info of the file stream you are playing not what your tv's refresh rate is.


  • Codec info displays info of the file stream you are playing not what your tv's refresh rate is.


    This is interesting because it's not what I've seen when I'm having problems. For instance I can be watching Fox news via mythtv/hdhomerun at 59.94, switch to a movie @29.97, then when I switch back to Fox I notice stuttering and codec info shows 29.97. Reboot is required at that point, kodi restart does not fix it. I do not see this behavior with refresh adjust turned off.


    I really need to sit down and take some more time to pin down the details (which is why I haven't filed a bug report.) But I need to understand what the actual expected behavior is in order to determine if it's a bug or user error. :-/

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME