xbox 360 controller does not work on libreelec 8.01

  • I'm in the market for a new box so i was testing kodi and libreelec on newer hardware (hp laptop with skylake core i3) and immediately found out there seems to be a big bug in libreelec 8.01


    At first i tried kodi installed on Windows 10 (store) plugged in my xbox 360 controller and it's get seen and works. Unfortunately the keymap i used doesn't work but that seems to be a kodi issue. They revamped everything.


    Second test was installing libreelec 8.01 and plugged in my xbox 360 controller, it get's reconized even asks if i want to configure it but nothing on the controller works. (not a single button, trigger, joystick) Whatever i try it's not working, i also put in my own keymap but still nothing.


    Third test was ruling out the hardware by installing old libreelec 7.0.1 and it immediately works so you have got yourself a BUG lady's and gentlemen!!


    The problem is... the box i want order is asrock beebox 7100 (kaby lake) so i need the newest version to take advantage of the hardware. But NOT without a working controller...

  • You have to map the controller in the controller configuration GUI. You have to use a working remote/keyboard to initiate the process.

  • You're wrong, have you tried it?


    Kodi 17 has a configure xbox 360 controller but it;s already preconfigured and should work out of the box, under windows 10 it has the same buttons preconfigered and works just fine. So the problem is not KODI but Libreelec.


    Whatever you configure, it doesn't matter because not one button/trigger of stick works under libreelec 8.0.1