Disabling the onboard RPi3 wifi? (Solved)

  • Possible to do it? Sometimes I find it overrides my dongle even though I have deleted all connections from it! Bizarre.

    Edited once, last by nickrob84 ().

  • Code
    echo "blacklist brcmfmac" > /storage/.config/modprobe.d/blacklist.conf
    echo "blacklist brcmutil" >> /storage/.config/modprobe.d/blacklist.conf
    reboot


    ^^ does that work?

  • Code
    echo "blacklist brcmfmac" > /storage/.config/modprobe.d/blacklist.conf
    echo "blacklist brcmutil" >> /storage/.config/modprobe.d/blacklist.conf
    reboot


    ^^ does that work?


    At work at the moment so will tell you this evening but if it does you have solved me a massive headache, so hopefully thanks in advance. Is that to be input via SSH all at once?

    Edited once, last by nickrob84 ().

  • At work at the moment so will tell you this evening but if it does you have solved me a massive headache, so hopefully thanks in advance. Is that to be input via SSH all at once?


    No luck I'm afraid, copied and pasted into ssh, no error messages but didn't reboot and then proceeded to send the wifi crazy resulting in a restore. Should I run each command separately?

  • Yes there are three lines there. The first two lines start with 'echo'. The last line is 'reboot' .


  • Yes there are three lines there. The first two lines start with 'echo'. The last line is 'reboot' .


    Thanks, will have another go in a bit.
    [hr]
    Nope, not working I'm afraid. Thanks for your help though.

    Edited once, last by nickrob84 ().

  • Repeated the process and it seems to have worked, should my dongle be showing as wlan0 now isntead of wlan1?

  • Nope. That's *exactly* the same as what I gave you, only the extra two lines Milhouse documented also disable Bluetooth.


  • Nope. That's *exactly* the same as what I gave you, only the extra two lines Milhouse documented also disable Bluetooth.


    Hi.
    I tried this way to disable the onboard wifi but it doens't work for me. I've put the file with this content:


    #wifi
    blacklist brcmfmac
    blacklist brcmutil


    I've tried with several names: "raspi3-blacklist.conf" and "blacklist.conf", both on config/.modprobe.d/.


    Then I reboot but the wifi interface that is online by default is always wlan0, and wlan1 is idle.


    Any idea? What I'm doing wrong?


    Thanks in advanced!