LibreELEC ODROID-U2/U3 support

  • Neither nor 8.0.2 work for me when flashed directly (they don't boot, red + dimm blue). 8.0.1 works fine though, as does updating via the tarballs after 8.0.1 is flashed. See below for their SHA1 as I downloaded them, in case they were somehow corrupted.

    8.0.2: 7ca20eae980ea214af0f4831f288146bc21c7c53 77752026d78924943c33925d0f3a3b2328906737

  • 8.0.2: 7ca20eae980ea214af0f4831f288146bc21c7c53 is the sha1sum of none of the images online.

    The sha1 of the 8.0.2 eMMC image is 367b76a2ca2e82c10feb1be2c3bcfa93407dc614

    The sha1 of the 8.0.2 SD image is ba6133e7d90464626542102f3317bf7ff7580293

    Edited 2 times, last by fraggle (June 4, 2017 at 11:21 PM).

  • Hello everyone!

    And many thanks to Fraggle for the effort of bringing latest LibreElec to U2/U3 !

    Due to subtitles security flaw, I’ve just moved from OpenElec 6.0.2 made by Zalaare (ODROID • View topic - OpenELEC for Odroid-U2/U3/XU3/C1), which I’ve been using for many years now. It was working perfectly well on my U2.

    I have a question. Does anyone is running LibreElec from this release on Odroid U2?

    I’m asking, because I have on version 8.02 (I also tried 7.9) I have problem video playback for most files – regular 1080p .mp4 movies, about 1.4GB size.

    Playback isn’t smooth, it very choppy. It almost look like playback has no hardware acceleration. But it has !

    In fact, it look like it’s played using the same decoder on OpenElec6.02 and LobreElec8.02.

    Info from OpenElec 6.02:
    D(Video: h264 (High) (avc1 / 0x31637661), you420p, 1920x1072 [SAR 1:1DAR 120:67],2049 kb/s)
    P(fr:23.976, vq:92%, dc:mfc-h264, Mb/s:1,53, drop:1, skip 2, pc:1)

    Info from LibrElec 8.02:
    Video decoder: mfc-h264 (HW)
    Pixel format: YUV 4:2:0
    Deinterlace method: hardware
    Video stream 1,920x1072 px, 0.00AR, 23.976 FPS

    CPU usages on both are very similar, and below 100%.

    OE6.02 playback is 100% smooth while LE8.02 is far from that :(
    Menus are smooth, but when there is paused playback in the background there are also very choppy!
    The problem is on default settings and I also spend some time for checking is other settings my help (video buffer, audio settings, sync playback). No luck.

    I also noticed, that in comparison OE6.02 in this version refresh rate cannot be changed, “Adjust display refresh rate” does not work and it fixed at 60Hz. I don’t know if this has something incommon.

    Is Anyone here with U2 and smooth playback ?

  • Hi Fraggle,

    Thank you for your interest in the problem.

    Sorry for a hude delay with the answer. I have a kitchen renovation.

    I took first free MP4 trailer of the movie:

    -I don’t know those files are usually zipped :(

    And the issue is very visible on it, especially on the beginning on panning scenes.

    The picture is not fluent, but has significant jitter of frequency 2-3 Hz.

    I have also filmed playback by phone on OE 6.02 and LE 8.02 so you can see the difference.

    LibreElec 8.02:

    LE 8.02 - Movie trailer MP4 H264 1080p on Odroid U2 - YouTube

    OpenElec 6.02 by Zalaare:

    OE 6.02 Movie trailer MP4 H264 1080p on Odroid U2 - YouTube

    Unfortunately played back on YT, difference is not remarkable as seen on TV (maybe due to poor recording or YT compression). The biggest difference can be seen on panning scenes, but jittering is also noticeable in nearly every movement.

    Media Info:


  • Thanks to Fraggle for the latest image for our beloved Odroids. I would like to know what is the equivalent config.txt file in Odroid like the one Raspberry has,in which you can control CPU fequencies and voltages. I am having heat issues with my Odroid and i would like to try and undervolt it and see whether that helps drop down the temps. I SSHed on my U3 but i could not find an equivalent file anywhere. Any help would be greatly appreciated.

  • Hi,

    I also have an issue with the resolution of my Odroid running Kodi. I just got the new version of kodi and now the resolution is pretty strange. It says 1152x864, I can't change it to 1920x1080 in the system settings as the option is grayed out. I already tried to set the resolution to Full HD via SSH

    (xrandr --output HDMI-1 --mode 1920x1080 --rate 60.0) but then the screen is just cut in half and the GUI is stuck in the upper left corner.

    I hope anyone knows what to do :D

    Thanks in advance!

  • Sorry for the delay ... was busy on other topics and finally found some time to test the videos.

    Could you please test the 8.1.1 beta images I've just made to see if the bug is still here?

    Do not forget to make a backup of your current installation before testing the beta !


  • Hi,

    thanks for your reply! I just tried the beta,

    unfortunately the resoultion is still 1152x864 and I can't change it, as the option is still grayed out. :(

    You will have to edit /flash/boot.ini to force the edid.

    In the video output section, comment out the sample line and choose the resolution .bin file matching your TV.

    Some displays send wrong edid informations.

  • Hi and thanks again,

    I tried that out but it also didn't solve my problem.

    The issue is, that if I boot up my Odroid the LibreELEC logo is displayed in 1920x1080 but as soon as Kodi starts the resolution is changed to 1152x864.

  • It shouldn't change given the u-boot edid parameters.

    Anyhow, the odroid-u2 LE portage use x11, so you could try all the supported resolution with xrandr and stick to one working with Kodi. Do this without forcing anything in u-boot.

    One you've found a working one, force it in boot.ini.

    Your display probably do not support 1080 HD natively, only 720 HD.

  • Hi Fragle,

    Thanks for considering our choppiness problem. And also sorry for the delay, I had to finish renovation of two rooms, beside the kitchen and a had no access to Odroid or TV.

    Unfortunately, choppiness is still here in LibreELEC-Odroid_U2.arm-8.2-devel-20170905122020-r26111-gbfacf5b6b :(

    I guess there is just the way it is, and U2 users with this issue just have to stick with OE6.02 version.

    Edited once, last by wydziub (September 24, 2017 at 11:39 AM).