How to force the audio minumum sample rate in Libreelec 8?

  • in previous versions I used the following in advancedsettings.xml

    Code
    <audio>
    <minimumsamplerate>48000</minimumsamplerate>
    </audio>


    In Libreelec 8.0 this is ignored. my Pioneer receiver doesn't play any audio that has a lower sample rate. How do I set this now?

    Edited once, last by Bloksel ().

  • XML
    <?xml version="1.0" encoding="UTF-8"?>
    <advancedsettings>
        <audio>
            <minimumsamplerate>48000</minimumsamplerate>
        </audio>
    </advancedsettings>


    This doesn't work?
    Do you have it set to "best match" in Audio output configuration, if so try "optimized" or "fixed".
    Can you post a log

    Edited once, last by vitorp07 ().

  • XML
    <?xml version="1.0" encoding="UTF-8"?>
    <advancedsettings>
        <audio>
            <minimumsamplerate>48000</minimumsamplerate>
        </audio>
    </advancedsettings>


    This doesn't work?
    Do you have it set to "best match" in Audio output configuration, if so try "optimized" or "fixed".
    Can you post a log


    Thanks for your reply. I only hear audio when I put it on fixed, but then I loose audio passthrough. Here is the Kodi Log

  • There is a lot of stuff in your advancedsettings.xml, for testing purpose can you make a copy of your current advancedsettings.xml, delete it and create a new one with just what i posted to see if that works.
    Reboot before testing


    Also, for testing only, set your refresh rate to 30Hz and check if it works.

    Edited once, last by vitorp07 ().


  • There is a lot of stuff in your advancedsettings.xml, for testing purpose can you make a copy of your current advancedsettings.xml, delete it and create a new one with just what i posted to see if that works.
    Reboot before testing


    Same, here is the log with a minimum of settings in advancedsettings.xml (I Need those settings to be able to play an audio file)


    Kodi Log


    It was working fine until I updated to Libreelec 8 a couple of hours ago.

    Edited once, last by Bloksel ().

  • Did you try this, set your refresh rate to 30Hz and check if it works.


    Maybe the patch was taken out of LibreELEC 8.0

    Edited once, last by vitorp07 ().


  • Did you try this, set your refresh rate to 30Hz and check if it works.


    Maybe the patch was taken out of LibreELEC 8.0


    Sorry, I missed that. I now tried it on 30Hz and then the sound works? But why not on the normal 60Hz?

  • Ok, thanks, at least I now have a workaround. I shall have to find out how to request it for a next update...

  • You should open a feature request and maybe the reason the patch was taken out is because another solution is out already.