LEv7 - VAAPI - Colour Space

  • I'm using LE and trying to replace win81+kodi on my NUCs but I'm having problems with VAAPI I think (crushed blacks and tearing).

    I was following a number of posts about colour space/vaapi/etc on kodi/OE forums and one mentioned a bug with VAAPI where the limited colour space setting is not honoured and instead full RGB is used. I have no option to adjust colour space on my TV.

    From - [FAQ] Video Levels and Color Spaces Demystified -- Get the Best Picture Quality

    • Kodi can be set to use limited video levels through the settings menu.
      **NOTE: There is a limitation of the VAAPI Hardware Decoder where it converts to Full video levels despite setting Kodi to use limited. To get limited video content to output from Kodi, you must disable hardware decoding in Video Settings for the time being. This will be fixed in Kodi 17

    Before I starting down a fruitless path can someone confirm if this is still an issue in LEv7? And is there any possible workaround at present (I've tried LEv8-alpha but it won't pass the WAF test).

    I've tried disabled VAAPI but as I'm using the Celeron NUC the CPU can't keep up with HD content and I have AV sync issues.


  • To work around this in LE 7 you can use this autostart.sh in .config:

    xrandr --output HDMI1 --set "Broadcast RGB" "Full"

    Assuming you are using hdmi1. You can confirm this by just running xrandr, and it will list the resolutions and output.

    In LE 8 this is not needed anymore.

    edit: Oh wait, you're the other way around, you get full rgb, but want limited?! Now I'm confused.

    Edited once, last by newphreak ().

  • What is waf test ( wife acceptance factor ? ) ?

    Since fritsch's oe build no problem with avshd test

    Same for libre 8

    Which tv are you speaking of ?

    If i remember correctly if av doesn't have full and limited setting...it's limited

  • Yes I'd like to use VAAPI with limited but at the moment when using VAAPI I get full and the picture is poor.

    Yes WAF = Wife acceptance factor. I test the LEv8 alpha builds but had random reboots and I have plugins which aren't supported yet.

    My TV is an old 48" Philips plasma and I believe only supported limited.

    Edited once, last by brianjg ().

  • Next time you try clean le8 install please post your xrandr --verbose and also report your problem in fritsch thread

  • Sorry to take so long, I tried settints full & limited values via xrandr but the colours etc were always a problem. For now I've had to disable VAAPI but this presents a problem playing some HD content. I'll see how it goes but may need to revert to windows+kodi :-(

  • probably you should show an example what you mean. Tearing was never a problem under Intel. That´s mostly a problem under NVidia. So a debuglog might be helpful.

    For the color range, newphreak said everything...so nothing to add to this. But probably you should look at your tv settings. If your NUC is set to full rgb your TV shouldn´t be set to limited and otherwise. Depending on the TV and what is available, you could set your TV to "auto". So it detects what it gets and uses that.