DV AVI does not show - Raspberry Pi 2, devel-20161129210859-#1129

  • I have a bunch of DV AVI videos (codec ID: dvsd). This is the format used by miniDV cams. I bet many of us have years of memories in DV AVI videos. Also, many analogue TV capture boards used this format. It was popular because it was easy to cut frame accurate without generation loss. So it was one of the most popular formats about a decade ago.


    I'm using a Raspberry Pi 2, LibreELEC (Milhouse) - Version: devel-20161129210859-#1129-ga26112d [Build #1129] 8.0, kernel: Linux ARM 32-bit version 4.8.11


    When I try to play a DV AVI video, the video does not show, the GUI stays on. The sound plays for a couple of seconds then it stops as well. If I go to the side menu of the GUI and select the full window icon then a blank screen is shown, and it shows the correct length of the video. The videos are marked as played after a while (probably after the length of the video has elapsed). Also, the thumbnails of the videos are shown in the GUI (browser view), with some format info (length, PCM, 576SD). I tried many videos: short/long, from capture card/from miniDV camera, but none of them plays.


    I can play all other formats: mkv, xvid, BD ISO, 3D as well.


    I tried to search for solution but the only mention of this was in the now closed Kodi development forum with only a repeated report of the problem without any solution, here: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0) and LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)


    The full debuglog is here: OCHW
    The mediainfo of a video is here: M8T4FmwE


    I also have an Amlogic S905 box with LibreELEC 7.0.3.010 that plays these videos happily. That debuglog is here: jRDa

    Edited once, last by kdan ().