Retroarch plugin (1.3.6) undefined symbol: xcb_send_request_with_fd

  • Hello,

    until Retroplayer gets pushed into LE i tried to use the retroarch plugin by  giuliano from here:

    I`ve installed the latests version (1.3.6) with a self-compiled master built of LE which is around two days ago.

    While in an older build of LE the 1.3.4 version of the plugin worked perfect I cannot get it to start with latest LE master.

    This is the error I get when I try to launch it from command line/ssh after install:


    MediaCenter:~/.kodi/addons/retroarch # ./
    error: XDG_RUNTIME_DIR not set in the environment.
    /storage/retroarch/default/bin/retroarch: symbol lookup error: /usr/lib/ undefined symbol: xcb_send_request_with_fds

    Directly in Kodi screen switches to black for about 1sec and then I am back at Kodi.

    Any chanches to get it working for the latest (master) version of LE ?
    What is the best solution atm to get an easy to use emulator interface to LE ?

    I`ve used Retroarch + IARL in the past which worked pretty well (the thingI do not want to copy games over to the shares).

    Edited once, last by Thomas233 (January 4, 2017 at 8:48 PM).