RPI 3b - Screen goes blank when changing screen resolution

  • I'm having an issue where the screen just goes blank when i change video modes on my pi 3b.


    My situation is a little bizarre because the display I'm using is sort of cobbled together.


    I've got the lcd panel from a thinkpad T43 - 15.1" 1400x1050 - connected to a universal (realtek based) lvds controller with hdmi and vga ports.


    The lvds board was programmed by the vendor - poorly. I'd need to buy a special programming interface to fix it.


    The chassis I'm using has a very old intel atom board in it. With xubuntu on the atom board, xorg boots up at 1280x1024 and with xrandr i can add and switch to the 1400x1050 60hz mode. I'd like to stop using the atom board because the pi3b is actually faster, not to mention all the video codecs it can decode in hardware.


    The real point of this chassis is the 3M 15" touchscreen. The original lcd panel quit working a couple years ago.


    The pi 3b always boots up assuming a 1080p display. At least, kodi thinks it's outputting 1920x1080. I wouldn't care except that it is assuming a 16x9 display but the physical display is 4x3.


    If i then select the 1400x1050 mode, the screen goes blank and never recovers. fwiw i am using a usb keyboard at this point.


    And if i select any other video mode, the same thing happens.


    I've tried editing the config.txt on the sd card. i've added the following lines:


    dtoverlay=hifiberry-digi
    dtoverlay=lirc-rpi,gpio_in_pin=26
    hdmi_ignore_edid=0xa5000080
    hdmi_group=2
    hdmi_mode=42


    The hifiberry option shows up in the audio output settings (haven't tested to see if the spdif actually works), so i guess i can assume that the file is being read correctly. But the hdmi settings don't make any difference.


    What are my next steps for troubleshooting?

  • So thanks for nothing.


    It might be helpful to know why hdmi_mode=42 didn't work. Like if some kind of error had been logged when libreelec or kodi rejected the hdmi stuff from the config.


    And it might be neat to know why manually selecting the mode in kodi doesn't work.


    But "hdmi_cvt=1400 1050 60 1 0 0 0" and associated hdmi_mode=87 did work.