Live TV with 7.90.009 on Odroid C2

  • I just got my Odroid C2 in the mail yesterday and installed 7.90.009 onto an eMMC. Most everything works as well or better than the same release on my RPi3 devices, but when trying to play a 1080i MPEG2 channel using the MythTV PVR plugin the video just freezes and never plays. If I hit stop, it goes back to the channel list. If I then look for recorded programs and find the Live TV program it plays back just fine. Recorded programs under "default" also play without issue, so the problem only happens when trying to watch in real time.


    Did I miss something? Is that a known issue with the C2 or more generally amlogic that isn't resolved yet? I saw where someone gave feedback on the blog post about 009 on C2 and said that TVHeadEnd was working for them. Without details on what is being played I am wondering if I need to change some playback settings.

  • I'm experiencing issues with 1080i 60Hz on my C2 running 7.90.009 too. It affects Live TV (stutters, freezes, crashes) and recorded programs (skipping doesn't work). I've seen other posts on the Kodi Hardware forum or Hardkernel forum indicating some low level coding is still required to get the C2 working with Krypton.


    Normally, I'd provide some logs/samples showing the issue, but I'm heading out on a trip for a few weeks and don't have the time right now. Maybe upload some logs to pastebin or sprunge and post the links to them.

    Edited once, last by doug ().

  • Yeah, I found some posts indicating there was some rework of the amlogic kernel bits after the change to VideoPlayer in Krypton. I just didn't know if 009 was expected to work yet or not. I'd be glad to post some logs if they're needed but it sounds like it is being worked on.

  • Using the 7.1.1 December wrxtasy release with Jarvis, liveTV works quite well. Hopefully live TV will be improved in Krypton soon. Appreciate all the hard work!

  • Updated to 7.90.010 and liveTV doesn't work or stops working rather quickly. Any idea when the updates for what is working with Jarvis will be available in an alpha Krypton release for the C2?


    Also, Merry Christmas to everyone!

    Edited once, last by zaphod24 ().

  • Hey zaphod24, you have almost the same build as me, instead of myth, I'm running the tvheadend client/server with hdhomerun tuners on the C2. I've had a bunch of trouble with 7.9, just upgraded on the weekend. I think I have the liveTV working better for now at least. Under Hardware Acceleration, I switched all those to Always. I think they were on HD and Up and I tried None, but Always works the best. For tvheadend, it also likes the htsp stream, but not sure if myth has similar settings for that. Good luck.