GXBB / S905 (ODroid C2) and LE 11.06 or 12 does not boot

  • I have written the 12.0.0 image and 11.0.6 image to a micro-SD card and put into my box. When I plug in the power cord, the red light comes on, but blue light never comes on and screen never comes on. It seems like this has been reported a few other times. Any suggestions here other than getting UART logs?

  • I've recently tested LE12 images booting from SD card and an eMMC module without problems. Are you using the "odroid-c2" image with upstream u-boot, or the "box" image? .. the latter has no u-boot so won't boot the board. If that's not the issue I'll need to see UART logs. NB: LE proactively disables the flashing blue LED activity indicator, but it will still flash at the start of boot until the disable script fires and stops it, which is usually around the time Kodi starts.

  • How can I tell the difference? I went here: https://libreelec.tv/downloads/amlogic/

    And downloaded LibreELEC-AMLGX.aarch64-12.0.0-odroid-c2.img.gz and LibreELEC-AMLGX.arm-11.0.6-odroid-c2.img.gz. Both showed the same problem. I suspect I am missing the "upstream u-boot". How do I get the image that includes that?

    Let me ask this, if I have a working SD card with a 9.2 image on it, can I just put one of those img files in the update directory and reboot? Or is there a better way?

  • Those are the correct images (so u-boot is included). You cannot update from LE9.x using those files as the image name is not the same as the legacy one; and if you manually override/workaround that it will fail in later steps because I intentionally changed the boot filenames to force people into a clean install: to avoid the accumulated cruft from old installs, and prevent add-on issues that cause problems with the Python2 > Python3 change since Kodi 19.

    See if https://chewitt.libreelec.tv/testing/LibreE…droid-c2.img.gz boots for you (it does for me). Please ensure the boot partition of the SD card is readable, i.e. prove you have correctly written the SD card and not just put the file on an SD card or direct-wrote the compressed image to the hardware (needs to be uncompressed). Do not rename files in the root folder of the SD card as done with some legacy images else it will break boot.

    I don't have any links to UART guides: As a rule people with UART cables have figured out how to use them. If you have one? there's probably some instructions on the Hardkernel wiki.

  • Hi,

    i hope it is ok to mention that i have also problems with booting the N2+ with Libreelec from either SD card or USB stick. N2 Petitboot is not showing anything on SD/USB stick. Only the eMMC (inserted all the time) content is visible to be booted. I had tried: LibreELEC-AMLGX.aarch64-12.0-nightly-20240517-4a0ed20-odroid-n2.img, LibreELEC-AMLGX.aarch64-13.0-nightly-20240521-738b75b-odroid-n2.img, LibreELEC-AMLGX.aarch64-12.80.0-odroid-n2.img

    When writing the latest Coreelec NO image to the USB stick it is fully booting via usb and listed in Petitboot beside eMMC to be selected. (CoreELEC-Amlogic-no.aarch64-22.0-P_nightly_20240522-Odroid_N2.img)

  • The mainline u-boot default boot method is extlinux.conf. Petitboot doesn't support extlinux.conf and HK devs have resisted the idea of adding support for some reason (more customers are forced to run BSP based images which keeps them inside the HK ecosystem perhaps?). Fortunately this dumbfcuk decision is easily solved by flicking the SPI boot switch to the right so Petitboot (which resides in SPI) is completely removed from the equation. Then LE boots fine from SD/USB and eMMC.

  • Ok. So, I used the 8gb micro-sd card that I was running on before, and flashed it with the link you provided above. I used balenaEtcher to write it this time instead of the LibreELEC creator app.

    I have an SD to micro-SD interface and then a USB to SD device. I have used this in the past, including this morning to write a pfSense image to another micro-SD card that booted fine on my router/firewall (upgrading to 2.7.2, but that's another story).

    When I put the card in the reader, I can see 2 partitions:

    I am also able to view the LIBREELEC partition and can open files:

    Same behavior as before. I plug power in, the red light turns on, no blue light, and after a few seconds the network jack lights start to blink.

    To make sure I wasn't crazy, I also wrote the 9.0.2 image from libreelec.tv to the same micro-SD card. This is the version that was on the card before and was running.

    I put the card in my ODroid C2, red light comes on, blue light blinks, monitor wakes up.


    I would really like to get a newer version of Kodi running as some of my apps had stopped working. Any ideas of what next steps I can take?

  • I plug power in, the red light turns on, no blue light, and after a few seconds the network jack lights start to blink.

    That comment ^ suggests the board is booting, because network LEDs blink because code tells them to, not magic. If you add "ssh" to boot params in extlinux.conf it will force the SSH daemon to start, allowing you to login over the network with an Ethernet cable connected to see what's happening. If you add "video=HDMI-A-1:1920x1080M@60" to boot params it will force the kernel to output 1080@60 on the HDMI connector, in case there's something odd with HDMI cables and the monitor. It's not a cure-all for an HDMI issue, but you'll have a screen to look at, maybe. Perhaps connect to a proper TV instead of a monitor?

    FWIW, I dug out my C2 board here and it boots fine using the image in my test share.

  • So my /extlinux/extlinux.conf file looks like this:

    Code
    LABEL LibreELEC
      LINUX /KERNEL
      FDT /amlogic/meson-gxbb-odroidc2.dtb
      APPEND boot=LABEL=LIBREELEC disk=LABEL=STORAGE ssh quiet systemd.debug_shell=ttyAML0 console=ttyAML0,115200n8 console=tty0 video=HDMI-A-1:1920x1080M@60

    I plugged it in. Blue light never comes on. Network lights come on after a few seconds. Mainly orange one, but orange and green will come on periodically. No output to display.

    I think I am going to have to put 9.0.2 back on it so I can get the MAC and then look for the MAC in my DHCP leases because I don't see the device show up in my DHCP leases.

    I will also try plugging it into a TV instead of a monitor to see what happens.


    I feel like I have to be missing a step. Do I simply use the LibreELEV SD creator, select the img.gz file, write to the micro-SD, then put into the device and boot? Or do I need to make changes after I have written the image?

  • Is it possibly related to using a micro-SD card instead of emmc? I have seen some threads indicating that was a problem, but I am not sure. I don't have emmc on my unit, and had previously used the micro-SD card to boot and run before. Would I need to add an emmc module, write the image there, and try again? At that point, I might just upgrade to a newer unit...

    Also wanted to note, I have the dedicated power adapter, the one with the small pin looking connector. I am NOT using a micro-USB cable to power the unit.

  • Do I simply use the LibreELEC SD creator, select the img.gz file, write to the SD, then put into the device and boot? Or do I need to make changes after I have written the image?

    Correct. No changes needed. All I can say is, current images boot/run/work here for me, and project stats (active installs) show that Odroid C2 boards are the most-used device with the AMLGX image. UART log showing early boot is the way forwards, as it will show exactly what is or isn't happening. NB: The same image boots from SD or eMMC.

  • Thanks twerty, I removed the jumper and put LE12 back on the micro-SD card. Same behavior as before.


    Thanks chewitt. Looks like you saw my other post. The really strange thing is that LibreELEC-Odroid_C2.arm-9.0.2.img.gz from the download page, and CoreELEC-Amlogic.arm-9.2.8-Odroid_C2.img.gz both write and boot fine.

    I just tried un-plugging ethernet, HDMI, and my USB keyboard and mouse, then powered on. Same behavior as before. Red light is on, but nothing else seems to be happening. I also plugged the ethernet cable in, and doesn't seem to be connecting to network.

    I am going to investigate getting the UART output. Let me know if there are any helpful resources.

  • Mainline kernel is pickier about the micro-SD card speed than the older kernel. Could be the card speed is too fast. I did have that issue with my C2 and moving back to a slower card made the mainline kernel happy.

  • smf007 any suggestions on which SD card to get?

    Sorry, I had gone back to the microSD cards I had gotten when I first got my C2s, so they would be rather old at this point. It's also been a couple years since those issues, so might be possible things have improved in mainline.

    If you need a new microSD card though, maybe try asking on the Armbian forum or the HardKernel forum. HK had a thread on the mainline kernel, think a few things about SD card speed was mentioned there
    Odroid C2 mainline kernel support - ODROID

  • Ok, so I finally got my UART-to-USB adapter working and got output:


    Here is the strange thing, it looks like it booted... Argh. I am going to connect a keyboard and mouse and see if it still works.

    So, if I do not have the UART cable plugged in, it doesn't boot. If I plug the cable in after a while, I don't get any new output.

    If I plug in the UART, then plug in power, it boots fine and I get UART output. Any ideas?