Wetek Play 2 can boot LE9 from SDcard without eMMC?

  • Hi all.

    I was using a Wetek Play 2 with internal tuner with the dtech LE 9.2.8 image installed on the emmc but it suddenly stopped booting. I think it is a hardware failure of the emmc chip.

    I have tried booting from the SD card with different LE9 images with no success.
    Booting from SD card with LE11 and L12 nighly images works but I can't use the internal tuner.

    Is there a way to boot LE9 on WP2 from the SD card without a working emmc?

    Thanks in advance.

  • Random guessing: image this to an SD card: https://github.com/LibreELEC/Libr…/bootloader.img

    Then write the LE 9.2.8 image to a USB stick, connect both SD and USB devices, boot and see what happens. If you're lucky it will find u-boot on the SD card, boot it, and then u-boot will find the LE 9.2 image on USB and boot the LE kernel.

    If that doesn't work, try the process again with https://github.com/LibreELEC/Libr…es/recovery.img written to the SD card instead.

    If you can connect the serial UART cable to the board to literally 'see' the boot process it will help you (else you are blind to what actually happens). WeTek did ship one with the box.

    The primary challenge you have is that S905 boards look for a signed boot header in different locations on SD/USB and eMMC boot media, hence an image of the factory Android image on eMMC (which we have) will not boot from SD as the SoC cannot find the signature. The LE 9.2.8 image does not include u-boot at all as LE relies on the factory u-boot being installed to eMMC. The LE12 image boots as this does include u-boot and the .img is specially built to have the signed boot header in both eMMC and SD/USB locations; but I doubt modern u-boot can boot the legacy images (have never tried). In theory it's possible to create your own Amlogic u-boot binary then sign it using the FIP sources in https://github.com/LibreELEC/amlo…ter/wetek-play2 .. but there's no guides for that kind of thing.

  • Thanks chewitt.

    I have tried both options with the same result: no boot from sdcard

    Attached the serial cable, console shows a boot loop:


    I also tried flashing your testing u-boot on sdcard (https://chewitt.libreelec.tv/testing/u-boot…bin-wetek-play2). The system boots, detect the USB but can't boot de LE 9.2.8, as expected.

  • The UART output at least confirms the box finds nothing to boot, which is a much better starting point for recovery activities than when u-boot is broken/half-working. And the upstream u-boot binaries in my testing share have no knowledge of boot files like kernel.img and dtb.img so it won't find and use them. However I'm wondering what happens if you simply rename stuff to files that it does know about?

    For kicks, create an SD card from the LE12 image for WP2 in my testing share and delete everything except the extlinux/extlinux.conf folder/file. Then copy kernel.img file from the 9.2.8 image (rename to KERNEL) and the SYSTEM file (leave as-is) and then dtb.img (rename to meson-gxbb-wetek-play2.dtb) and see what happens when it tries to boot (share the UART output and/or dmesg should it make it that far). I'll be surprised if it works, but you have nothing to loose.

  • No surprises chewitt, tested following the instructions with no success: Bad Linux ARM64 Image magic!

    This is the console output (lines about PHY for ethernet removed):

  • Flashed u-boot to SDcard with LE9.2.8.13.

    The console output:

  • The last line contains the clue .. that's the Hub u-boot binary not the WP2 one. I'll see if I can regenerate the WP2 one (needs some setup as those files were last built on some other machine).

  • The last line contains the clue .. that's the Hub u-boot binary not the WP2 one. I'll see if I can regenerate the WP2 one (needs some setup as those files were last built on some other machine).

    I would appreciate if you can do it to test if could boot LE9 from SD.

    Watching TV on the WP2 with LE11 and an external USB DVB stick is painful, after a few minutes the artifacts begin and tvheadend shows a lot of continuity counter errors, making it unusable.

    Perhaps the best solution is to buy new hardware. 8)

  • diagus

    Here's a Play 2 u-boot that will boot by default from sd card (unless you press the remote power button, in which case it will try to boot from eMMC, which in your case and mine, doesn't work).
    Just write is to the sdcard where you have LE9 and it should work.

    Just one note, the screen will be black for a few seconds on bootup in case u-boot cannot find the boot splash image in eMMC


  • Thank you very much ricopt5. It works!!! My WP2 boots LE9 form sdcard. :)