11.0.6 and LE12 Nightly Audio/Video stutter and delay when started from playlist m3u

  • When I open a playlist m3u file and start a youtube link from it, the audio starts for 2-3 seconds, than stops for 5 seconds, than audio/video jumps to a later timestamp in the video. 11.0.3 didn't show this and no other way I start the video (sideload or direct from YT addon).


  • Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem
    4. Generate a log URL (do not post/upload logs to the forum)

    use "Settings > LibreELEC > System > Paste system logs" or run "pastekodi" over SSH, then post the URL link
  • It's still the same issue that you had on your last thread. Same solution: Update your server to NFS4.

  • So, kodi, even in LE 11.0.6, doesn't work with nfs v3 anymore?

    This half-life of nfs v3 is bad, would be better if you don't get access at all.

    Update: I copied the playlist file to the local SD, started a youtube link from it, exact same behavior. Does that means that the existence of an nfs v3 link is enough to slow everything down?

    Edited once, last by insulator: New test (February 14, 2024 at 6:33 PM).

  • 1. Next test with LE 12:

    - Removed all links to the nfs v3

    - the 2nd nfs v4 device included, but offline

    - playlist file on local SD


    Started youtube link from playlist file, exact same behavior. During the 5 sec delay the screen froze incl. all debug messages.


    2. Same as above but with booted nfs v4 device:


    Error gone. So, looks like nothing with the version number, but with offline nfs devices itself?


    3. Same but with nfs v3 device included and online:


    Error gone. So, like my other thread, all nfs devices must be online.

  • I installed nfs v4, switched the nfs option to version 4 in settings, no change.

    For years of using Kodi my network infrastructure was never a problem until now.

  • I have 2 RPI3 running Libreelec (3 and 3+), they are connected to a 3rd RPI running bookworm with NFS server v2/v3/v4 and a QNAP with NFS v2/v3/v4 activated.

    On the RPI running bookworm are videos and playlist files. Everything is running ok when the QNAP is online. As soon as the QNAP is off, the errors accessing the bookworm NFS begins.

    Delays in accessing video files or just going through the file structure and the strange behavior when I try to play a video from the playlist file located on the bookworm NFS device.

    The RPI3 running LE 11.0.3 has not such problems.

    Just a quick idea: Is there a message queue in the background flooded with error messages from the offline QNAP NFS device?

    Hope this helps

  • I tested OSMC:

    1. Connected the NFS device at the RPI bookworm but not with the QNAP, so was unknown to the system

    2. opened the playlist file

    3. run a youtube link

    same error -> has therefore nothing to do with the missing NFS connection to the QNAP, or?

    -> originated in Kodi itself, or youtube addon?

    I looked in the error log and it said frequent "NFS Mount error" but why? The link I opened was a YT link.

    The explanation I have is that Kodi, despite I want to open a YT link, looks inside the whole playlist file for invalid links. So, I made a playlist file with only YT links which are valid and voila, error gone.

    Kodi looks into all playlist file links if they are valid (?)

    After this error, Kodi is slow. In older versions of Kodi, it was different.

    OT: In OSMC the youtube addon has problems by itself