"Connection Closed" when trying to download image.

  • Hi there!


    I'm trying to get LibreELEC on a micro-sd card for my Cubox-i4pro.
    I'm using the USB-SD Creator and when I get to the part where I download the file the following happens:

    • I select the location to which the file will download.
    • The download starts and pauses at a random percentage (I've tried multiple times and each time it stopped someplace else).
    • The writing in the loading bar shows "Connection closed"


    I didn't find a post regarding this issue in the forum or anywhere else.


    What can I do to fix this? I tried to find the image and download it directly but to no avail.


    Thanks in advance,
    Asaf P

  • Get yourself proper internet connection? :rolleyes:


    You can download image directly on LibreELEC download page - but it is little hidden.
    LibreELEC-imx6.arm-7.0.2.img.gz
    LibreELEC-imx6.arm-7.90.008.img.gz


    Support my work with small (or big) Paypal donation


    Amlogic devices works better with CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)


    Edited once, last by vpeter ().