NUC 7th Gen i3 CEC

  • To preface, I've been using Raspberry Pi 4's for my LibreElec/Kodi/JellyFin clients for a while, and was using the same RPi's when I was using Plex, and all was well. I have RPi4's at three locations, two of which the CEC works perfectly at and the third I've never gotten it working, but while that's not really relevant to this topic, I'll touch on it in a minute.

    I acquired a NUC with a 7th Gen i3 that supports H265 decoding and whatnot, and so far, it seems to be working really well. It, unsurprisingly, seems to be quite a bit faster than the RPi4's. The one thing I haven't gotten any part of is the CEC. On the RPi, in the location I'm testing the NUC ('Mancave Theatre'), I've never gotten CEC working, although it was listed in devices in LibreElec. I believe the reason it hasn't worked is because the RPi, a FireTV, 4K BlueRay player and XBox are all plugged into my Sony A/V receiver and the output on the receiver is then connected to an input on the TV. I suspect the receiver is intercepting/blocking the CEC signals to/from the TV. If anyone has any ideas as an aside, I'm all ears as I'd love to have it work. But on topic, on the NUC, I don't even have a CEC adapter listed. I did some reading suggesting disabling CEC in the BIOS, which I tried (It was enabled by default), but no change. Still no CEC adapter listed. Now, I may never be able to get CEC to work in this particular location due to the topology, but it does work at my other two locations, and based on my initial perceptions, I'm inclined to gather a few more 'older' NUCs for my Jellyfin clients in place of the RPi's. But at the other two locations, if I can't get CEC working, that's a non-starter.

    What I was able to find suggesting that CEC wasn't supported 'yet' was from back in 2017 or 2018, and I think for 8th gen based NUCs, but here we are in 2023, so I'd think a 7th gen would be totally 'figured out' by now.

    Does anyone have any thoughts/suggestions on how to get it to CEC to work in LibreElec/Kodi on a 7th gen based NUC?

  • Well, main reason is the NUC is available, while the RPi's are non-existent (locally, at least, and where available online, they're overpriced, at least from what I've found).

    For the 7th gen, yes, I set that as the oldest generation processor due to H265 support (nearly all of my movies are encoded H265 using Handbrake). I don't recall if that started in the 6th gen or 7th gen, but it's definitely in the 7th gen, so that's where I set it. Initially, it was an experiment, in part due to the unavailability of the Pis, but after setting it up, overall, it seems vastly superior. The Pi4's do work, for sure, I've been using RPis for a long time in this capacity, but although it's hard to definitively quantify, the video playback on the NUC seems to be smoother. In certain situations, the Pi's seem a tad jerky. I did find one oddity on the NUC that I'll have to post a separate thread on though.

    Of course I wouldn't spend over $300 for a single NUC, and that's part of the reason why the RPis were attractive (cost), but I was able to get this NUC for $80, which is about what Raspberry Pi 4's are listed for on Amazon, and the Amazon pricing is at least 50% more than they should be selling for.