Intel NUC11PAHi5 - Audio over HDMI fails, but audio over DisplayPort works

  • Hardware - Intel NUC11PAHi5, fresh out the box

    OS - LibreELEC-Generic.x86_64-11.0.0.img.gz

    BIOS/UEFI - the latest version, updated twice (for some weird reason Intel specifically says to upgrade twice)

    BIOS settings - couldn't find anything audio related beyond an option to enable/disable the entire onboard audio

    Passthrough - currently disabled

    TV - Samsung UN40KU6300

    Speakers - TV built in (just for testing)

    Logs -

    My old setup on a NUC6 had HDMI audio as expected, but it was having some other unrelated problems, so I decided it was time to upgrade. Put a bare LibreElec install on the new one to test everything, worked fine, except... no sound. Now, I can see 4 HDMI ports + Bluetooth in audio settings, as expected. I'm not 100% sure which one is the "real" HDMI port (as opposed to DisplayPorts), so I tested output on each port after every change.

    Went through a whole bunch of debugging, and eventually thought it might be a port problem. Having no proper DisplayPort cables on hand, I took a very long shot and used the current HDMI cable hooked up to an HDMI > mini-DP adapter. To my extreme surprise, it worked. Let me say that again: An HDMI cable plugged directly into the HDMI port produces no sound even after testing every HDMI audio output port in settings. However, taking that exact same cable, hooking it up to an HDMI > mini-DP adapter and plugging it into the mini-DP port on the NUC produces sound once the correct port is selected in settings.

    If I just need to switch to DP, that's probably fine. I'm not doing anything exotic where it would make that much of a difference. At this point I just want to know what the heck. Is there something physically wrong with the HDMI port or what?

  • i regret buying NUC11 PAH i3

    On mine I had no signal on HDMI and only works on Mini DP to HDMI adapter like you.

    I was not able to get a refund though.

    NUC12 Essentials had no issues but no longer have that but it lacks IR and even HDMI CEC