DS3231 RTC hwclock ssh cmd error message

  • I have the following LibreELEC setup:


    Hardware: RaspberryPi2


    LibreELEC build version: 7.0.0, kernel: Linux ARM 32-bit version 4.4.7


    I am having trouble setting the RTC in ssh. Getting the error message (hwclock: can't open '/dev/misc/rtc': No such file or directory)


    I have done a clean install on different SD card and added the line to my config.txt.

    Code
    dtoverlay=i2c-rtc,ds3231


    I was using OpenElec version: 6.0-retroplayer-20160304094500-r21909-gc5fa697 and it works great there. Tryed copying working config.txt from Openelec and still no go.


    I also tryed to add the line

    Code
    dtparam=i2c_arm=on


    or the line

    Code
    dtparam=i2c=on


    and its still not working.


    I have uploaded the following files to a pastebin site:


    Please help, my RaspberryPi PVR media centre is not connected to the internet.


    Thanks in advance.

    RPi3+ LE v8.2 (+ HDHomeRun ATSC tuner, Tvh, Comskip, zap2epg)
    A95X LE v8.2 (kszaq)


  • Seems that the kernel config option isn't enabled.
    LibreELEC.tv/linux.arm.conf at libreelec-7.0 · LibreELEC/LibreELEC.tv · GitHub

  • Yes it's working, but doesn't keep the right time for some reason. Like right now it says Sun Apr 23. I have Internet access right now so I'm using the net time, but that's ends in 2 months so I need to figure out why the Rtc isnt keeping time.


    Sent from my SM-G900R4 using Tapatalk

    RPi3+ LE v8.2 (+ HDHomeRun ATSC tuner, Tvh, Comskip, zap2epg)
    A95X LE v8.2 (kszaq)