kodi is not loading channel icons from TVheadend server

  • der all!

    I read through the forums a lot, but I couldn't find a solution, so I'll have to ask:

    • I run a headless tvheadend server HTS Tvheadend 4.3-2027~ge3f4f222e at the home network ip 192.168.8.2
    • I configured all my channels with custom channel icons, and
      • the tvheadend webpage at 192.168.8.2:9981 shows me the correct channel icons in the EPG tab, so that looks fine.
      • I have the android TVHclient app installed on a tablet, and this app displays the correct icons
      • my libreelec Kodi client does not donwnload and show the channel icons
    • I run libreelec 10.0.3 on a RPi4 with the tvheadend addon. I have an unpriviledged login, say MYUID:MYPWD. All the programs play just fine, EPG loads just fine.
    • configuration of the TVheadend server is, amongst other things:
      > config > general > image-cache: NOT ENABLED
      > config > general > base: http sever settings ==> authentication type = "both plain and digest" (this seems to be the safest and working config)
      > config > general > base: http sever settings ==> realm name = "tvheadend" (this is different from the username that the kodi-clients use, I guess this is ok)


    However, libreelec / kodi does not load the channel icons from tvheadend server: the ~/.kodi/temp/kodi.log file gives me errors:


    Code
    2022-12-01 00:31:54.891 T:822 ERROR <general>: CCurlFile::FillBuffer - Failed: HTTP returned error 403
    2022-12-01 00:31:54.891 T:822 ERROR <general>: CCurlFile::Open failed with code 403 for http://192.168.8.2:9981/imagecache/428:
    2022-12-01 00:31:54.891 T:822 ERROR <general>: CFileCache::Open - <http://USERNAME:[email protected]:9981/imagecache/428> failed to open

    I guess the kodi clients use USERNAME=MYUID and PASSWORD=MYPWD and this is just not written plaintext into the log file.


    note: when I paste http://MYUID:[email protected]:9981/imagecache/428 into any browser on any pc on my intranet, the correct channel logo is shown, so the tvheadend server holds the icons available for the clients.


    So, somehow it seems to me that libreelec/kodi doesn't authenticate correctly to the tvheadend server for the purpose of loading the channel icons, but authenticates correctly for the purpose of downloading the video stream and EPG...


    Things I've tried:

    • I cleared all caches from the libreelec/kodi UI, even uninstalled an reinstalled the tvheadend addon
    • I deleted ~/.kodi/userdata/Database/Textures13.db file but this obviously didn't change the behaviour

    What do I do wrong? Is this a bug in the tvheadend-addon, in kodi, in libreelec?


    thanx 4 support