RPI4 Nightlies Crash System from 20220723-0008ab5

  • On my RPi4 2GB I've been testing and incrementally updating nightlies until LibreELEC-RPi4.arm-11.0-nightly-20220721-06fd018


    Each update from LibreELEC-RPi4.arm-11.0-nightly-20220723-0008ab5 onwards, crashes the system.

    Failed restarts eventually cause it to start in safe mode.

    Having a look at the logs, I see a DBus error: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files


    Other than that, I can see an error relating to missing html tags in Repository add-on repository.zachmorris. I have looked for that repository in my addons but haven't been able to find it though it appears to have something to do with gaming (which I don't do).


    Crashlog is at:

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Hope someone can have a look....


    Thanks!


    P.S. For clarity I should mention that after each failed attempt I restore a backup image of my working 20220721-06fd018 system. I have also tried different SD cards and a USB3.0 stick.

    Edited once, last by deepee: Clarification ().

  • Thanks that worked :)


    Using my restored pre-update system, I uninstalled TvHeadend client (20.3.0.1) from addons using the Kodi GUI.

    I deleted the /storage/kodi./addons/packages folder and contents using WinSCP before copying LibreELEC-RPi4.arm-11.0-nightly-20220727-fcc8f2f.img.gz to the /storage/.update folder.

    After rebooting without error, I re-installed TvHeadend client (20.3.0.1) and everything is now working correctly.


    Thanks again HiassofT

  • Also here but can't find in the log any addon related error except some old repository addons.

    There something with edid and alsa but it is more kernel related or?


    Maybe someone is willing to shed some light for me?


    http://ix.io/46eM


    RPi4 with LibreELEC-RPi4.arm-11.0-nightly-20220720-3a4dc81 is also the last working one for me.

    Safemode works.



    Update:


    Re-created the edid.bin with:

    Code
    getedid delete
    getedid create


    Deleted the pvr.iptvsimple with:

    Code
    rm -rf .kodi.FAILED/addons/pvr.iptvsimple
    rm .kodi.FAILED/addons/packages/*
    reboot


    Updated to LibreELEC-RPi4.arm-11.0-nightly-20220730-c9c09cc successfully!

    Edited once, last by Cris_ ().

  • Cris_ the hint is/was in the crash dump:


    At the very beginning it says it crashed in thread 1:


    Code
    Program terminated with signal SIGSEGV, Segmentation fault.
    #0  0xf7853198 in strlen () from /usr/lib/libarmmem-v7l.so
    [Current thread is 1 (Thread 0xc8cfc240 (LWP 1657))]

    Then a bit down look at the backtrace of thread 1 and you see it crashed in pvr.iptvsimple - that's the offender

    so long,


    Hias