Generic Intel Nightly DRMPrime decoder with 544x576 broadcasts (audio only)

  • I have started using the nighty builds a lot for testing and I mainly use libreelec as a PVR for FreeviewHD.

    I have noticed that if I enable the DRMPrime decoder, any SD channel that is streamed at 544x576 resolution does not display video - either with or without DRMPrime hardware support enabled, though I can still hear the audio and the channel does continue to stream. Other HD and SD resolutions appear to work without issue. All streams do playback ok using VAAPI with MPEG2 HW enabled and DRMPrime disabled.

    Is this just a limitation of the DRMPrime decoder that will eventually be updated to support bandwith friendly resolutions such as 544x576? or is there something I can do wih TVH streaming to output this correctly at 720x576 to allow these to play using the DRMPrime decoder?


  • I've tried to search for this issue in various forums and can't really see anything relating to this issue with the DRMPrime decoder.

    Is it just a case that the decoder currently does not know to stretch 544x576 to 720x576 and sees the video stream as invalid but the audio steam as valid?

    This is still quite a common resolution for terestrial dvb broadcasts in the uk.


  • Hi,

    I've noticed a few updates to the DRMPrime decoder recently, but this issue persists for me.

    Is this issue just me? Or is this something that is going to be addressed at some point for the DRMPrime decoder?

    I am currently running Intel Generic LE11 nightly build with AMD RX550 GPU and this is the only issue keeping me on VAAPI atm.


  • I can't answer your question, but I've seen similar (NOT running DRMPrime !): green or blue screens while audio is playing

    my fix was:

    - when the video is playing

    - press Enter key

    - move to the most right

    - press enter

    - adjust - I guess - it was "resolution"

    can't remember if I switch temp. to another channel, adjusted it there and switch back to the problematic one.

    in my case: I had only some minor attempts before the box crashed/restarted

    don't know if it will help here too I don't use DRMPrime cause - AFAIK - it's decoding (?) in software not hardware

    => O-key while running the channel

    Edited once, last by GDPR-7 (August 13, 2022 at 11:01 PM).

  • Thanks,

    I have rolled back to LE10 for now, if I try LE11 again I will be sure to try your resolution change suggestion. I also wasn't aware that decoding in DMPrime was being done in software even if hardware acceleration is selected? It did seem quite a good picture and very smooth on the UK 1080 HD channels which isn't the case with VAAPI software rendering which is noticeably worse for me than hardware VAAPI.

    Thanks for the help JoeAverage

  • what was the reason switching back to LE10.

    LE11 has newer components (kernel, etc).

    I'm running LE11 nightly with DRMPrime OFF and without errors since month.

  • I needed chrome to work and LE11 generic-legacy didn't seem to work for me when I tried it.

    If not for chrome I would have been happy running LE11 as I had no issues other than the DRMPrime one.

    I may try LE11 generic-legacy again at some point.

  • I just wanted to update this in case it is useful information for someone.

    I updated my HTPC to 6th gen intel, which meant I didn't need the extra amd rx550 GPU for vaapi (was previously using i7-3770k IvyBridge).

    I have no issues with DRM Prime at all now with 544x576 SD channels. I also used to have regular crashes (kodi just suddenly restarting) when forwarding/rewinding TVHeadend TV recordings using AMD VAAPI (far more in LE12 than LE11) but this has now also stopped happening.

    So, in hindsight, all of the issues I had were likely down to the AMD RX550.

  • Hi, I don't use DRMPrime, I use VAAPI - but when I was having a lot of issues with VAAPI with recorded tv always restarting kodi when FF/RW I tried DRMPrime as an alternative and noticed the 544x576 issue.

    I have no issues in either VAAPI or DRMPrime now that I have upgraded to Intel IGPU only HTPC and dropped the AMD Card. DRMPrime works fine on generic for me apart from the lack of deinterlacing, which is why I use VAAPI anyway.

    The update to this old post was just for information in case other people have similar frustrations.