wpa_supplicant configuration on LE10

  • Hi, I'm trying to connect my Raspberry Pi4 to an wpa2 enterprise network.

    I have a working wpa_supplicant.conf, copied it in .cache, it is the same I'm using on another Pi4 connected to the same network, but I don't know how to start wpa_supplicant using it.

    I tried checking in STORAGE/.config/system.d to edit the systemctl script, adding:


    Code
    ExecStart=/usr/bin/wpa_supplicant -u -iwlan0 -Dnl80211,wext -c/storage/.cache/wpa_supplicant.conf

    but without success.

    Can anyone help?


    Thank you.

  • shouldn't that be


    systemctl restart wpa_supplicant.service


    and to check if started:

    systemctl status wpa_supplicant.service

  • Not that easy. It seems Libreelec does not use a specific wpa_supplicant.conf, that's what I need to achieve, but I need access to systemd to do that

  • LE uses ConnMan to manage wireless connections. ConnMan uses wpa_supplicant as a library (for now, until we switch to iwd) but you cannot configure connections that way. ConnMan supports connection to EAP networks, but our GUI is aimed firmly at dommestic users and does not implement support for configuration. However you can still create an appropriate *.config file under /storage/.cache/connman with required details and it will work (over the years there are a small number of reports of people doing it).


    See https://manpages.debian.org/te…-service.config.5.en.html for the large array of possible options and some examples.