Playback issues with YouTube Addon

  • Over the last several months this issue where playing youtube videos pause and hickup I think because they cannot buffer fast enough. Only recently over the last few months has this become a problem and it seemed to get worse over time. I used to watch the youtube addon alot and now its to the point where almost everything is unwatchable. I tried looking at the settings and changed the cache setting but didn't seem to change anything. I verify that it is still an issue using advancedsetting.xml or not as it is the same on two kodi machines I use. Not having issues with other addons that stream like BitChute to where you might think I have a bandwidth problem. Just the YouTube one.


    Any ideas?

  • See:https://forum.kodi.tv/showthread.php?tid=356934

    Buffering Bug · Issue #163 · anxdpanic/plugin.video.youtube
    Add-on Version: 6.8.15 Kodi Version: 18.9 Kodi GUI Language: English Operating System: CoreELEC 9.2.7 Hardware: ODROID-C2 (Amlogic S905 SoC) Operating System…
    github.com


    Youtube is deliberately throttling unofficial clients.

    There are some workarounds and alpha1/alpha2 versions of the plugin fixed it for me (although some are still reporting issues).


    This drove me mad as it's gradually got worse over the last few months.

  • Ah, that makes sense. I guess I'll just quit using it for now and try again in a few months. Theres lots of good stuff on bitchute too.

  • Youtube is deliberately throttling unofficial clients.

    There are some workarounds and alpha1/alpha2 versions of the plugin fixed it for me (although some are still reporting issues).

    Yeah it's still happening even with the alpha2 version for me, it's tough when I am vegging out watching retro computer videos from a playlist.


    The best UX for YouTube is Cast Kodi browser plugin, hardly ever use the addon's browsing features.

  • I use sendtokodi (so I can browse videos from phone and then choose share/sendtokodi and video plays on TV).

    sendtokodi was hit by the youtube throttle, but I described a fix here

  • The alpha1 version fixed it 100% for me. It's strange that the alpha release works fine for some and not others.

  • I use sendtokodi (so I can browse videos from phone and then choose share/sendtokodi and video plays on TV).

    sendtokodi was hit by the youtube throttle, but I described a fix here

    Yeah, I was thinking perhaps this is part of my problem. I don't think Cast Kodi is passing the n parameter, but I was assuming that the Youtube plugin was using the video id and scraping the HTML page to yank that parameter out. Is that not the case?


    Worth mentioning what Cast Kodi does is sends a plugin:// URL to the playlist.

  • Just found the iphone app sendtokodi, thanks to some of the replies here. Did not even know there was one. I'll try that and see if it works.

  • Just found the iphone app sendtokodi, thanks to some of the replies here. Did not even know there was one. I'll try that and see if it works.

    It will have the buffering intitially but run the commands in the linked issue and it should work.

  • I still have this issue even after updating to alpha2. Any other ideas?

    There are other tips on the Kodi/YouTube Addon Forum but they don't work for everyone. This issue is well known and there are people working on fixes. Be patient.

  • Have a look at the German language kodi.nerds. There is a workaround that works.

    Raspi 4, Argone One m.2,LibreElec 10.0.2

  • I've tried,

    Code
    plugin.video.youtube-unofficial-6.8.18.alpha2+matrix.1.zip
    
    plugin.video.youtube-6.8.18.alpha2+matrix.1.zip

    with and without mpeg-dash enabled.


    Cast Kodi browser extension.


    Still same buffering issue.

  • Can confirm with alpha3, buffering issue is resolved, tested 720p videos for few hours. Subtitles not working.


    Kudos to the devs.

  • Can confirm with alpha3, buffering issue is resolved, tested 720p videos for few hours. Subtitles not working.


    Kudos to the devs.

    Personally, I had no problem with 720p, only 1080p.

  • Personally, I had no problem with 720p, only 1080p.

    That sounds like a general internet (or wifi) bandwidth issue rather than the throttling issue. When throttled you can't even watch 480p without buffering.