4K runs slow motion and only 1920 x 1080

  • 4K runs slow motion and only 1920 x 1080

    From as requested by Christian Hewitt, and I hope I'm doing this correctly please be gentle if not.


    I have just downloaded the version Kodi 19.1 (Linux Kernel 5.10.x)

    LibreELEC-RPi4.arm-9.95.5.img.gz


    Run the image to my MicroSD card and checked the config.txt file there was not mention of hdmi_enable_4kp60=1 I have added that in, and booted the Rapsberry Pi 4 B which is the 8GB RAM also a mention on the released version LibreELECT 9.2 I was able to use the iPhone Kodi Remote app. With this version I have not been able to connect with that so I am using a Wired USB Keyboard and Mouse.


    On boot up it showed on the Bauhn 75" 4K panel that it was displaying at 1920 x 1080 and at 60 Hz no changes there like the previous run.


    I must apologies for the screen shots, I thought I would be able to SSH to the Kodi and get the log files but that's not working either.


    4K runs slowmotion and only 1920 x 1080 · Issue #5496 · LibreELEC/LibreELEC.tv · GitHub

  • Clean install the current nightly from Index of / with no 4K60 configuration and prove things work normally and the RPi4 can see 4K (up to 30) modes - right now it is only seeing 1080p. That suggests bad or inadequate/uncertified HDMI cables (or broken EDID from the TV) or using the wrong HDMI port on the TV. Note that LE defaults to [email protected] GUI even if the TV supports 4K playback. Rendering the GUI is about CPU performance, it is not hardware accelerated like 4K video, so the GUI will be noticeably slower if you force it to run at 4K. You can still whitelist 4K modes for playback and Kodi will switch to 4K when required. Also note that practically all 4K media is [email protected]/25/30 so in most cases, users do not require 4K60 to be forced.

  • Hi and thanks for getting back so fast :-)


    So I don't muck anything up am I correct in thinking the syntax of the file would be;

    LibreELEC-RPi4.arm-10.0-nightly-<date__version>.img.gz

  • Sorry it's plain as day once you read it isn't it :-) anyway. I've just tried

    LibreELEC-RPi4.arm-10.0-nightly-20210718-2e9262e.img.gz


    With the same result, so panel is showing 1920 x 1080


    No change in the display settings.


    Also side note the iPhone Kodi remote still will not connect when using this version am still using a USB mouse and keyboard.


    I have also tried connecting to one of the other HDMI inputs on the panel, this one currently has a HDMI Upscaler between it and my receiver, the receiver only processes 1080 p the upscaler shows on the panel as 3840 x 2160p_50Hz if I use just the HDMI cable to the panel I still only get 1920 x 1080_50Hz


    The smart side of the panel runs Netflix 4K with out issues as does Youtube. There is also and inbuilt media player which allows DLNA access so I can stream 4K from my NAS devices without is. It is very clunky which is why I'm trying to get a more functional solution. I say this as I'm certain the panel is certainly running 4K happily.

  • I ran up the LibreELEC-RPi4.arm-10.0-nightly-20210720-4f77520.img.gz today.


    Everything appears the same except this time during the Kodi 19.1 start up a banner on the right top popped out with I think CEC something but it did show the Model Number of my Onkyo Receiver, interestingly that is on HDMI ARC so downstream of the monitor connection to the Pi4 display resolution is still 1920x1080_50Hz


    The iPhone Kodi remote still doesn't connect so using USB mouse and keyboard.

  • OK kind of a bit of one step forward and stop...


    I went into LebreELEC add on and upgrade and set the EEProm to update to more recent as per screenshot actually not sure if it was after in which case it probably doesn't show the earlier date but it was like last year sometime. I thought I'd already done this previously but....

    Anyway once reboot occured the panel started displaying 4K settings as per screen shot below. But when I try and play a 4K movie it just well hard to explain not shore if it's locked but the mouse like trails when moved around the screen.

  • Ran up and installed last nights build

    LibreELEC-RPi4.arm-10.0-nightly-20210721-4f77520

    The version number looks the same to me however the date has changed I guess that means no changes?

    Anyway booted up immediately into 3840x2180p_60Hz and stayed at that resolution right up to the Kodi screens.

    Playback of 4K network 1GB movie is still frozen or I should say jittering appears to be vertically over a 2 cm area on a 190 cm screen with a snail trailing mouse. Also local USB drive playback of 4K does exactly the same.

  • I just borrowed for testing LG Jazz HDR UHD.webm and copied it to the .storage/video folder of the MicroSD card.

    \\libreelec\Videos

    It plays much better but is in slow motion.

  • Please enable debug logging. Then try to play the file that doesn't play properly, then post the log.

  • RPi4 doesn't support vp9 decoding IIRC. You will need to use HEVC files to be able to do 4k HDR


    Code
    2021-07-22 14:37:51.996 T:2515526512    INFO: ffmpeg[95EFE370]: Input #0, matroska,webm, from '/storage/videos/BEST HDR DEMO FOR TVs _ 4KHDR TEST.webm':
    2021-07-22 14:37:51.996 T:2515526512    INFO: ffmpeg[95EFE370]:   Metadata:
    2021-07-22 14:37:51.996 T:2515526512    INFO: ffmpeg[95EFE370]:     ENCODER         : Lavf58.20.100
    2021-07-22 14:37:51.997 T:2515526512    INFO: ffmpeg[95EFE370]:   Duration: 00:03:58.42, start: -0.007000, bitrate: 7010 kb/s
    2021-07-22 14:37:51.997 T:2515526512    INFO: ffmpeg[95EFE370]:     Stream #0:0(eng): Video: vp9 (Profile 0), yuv420p(tv, bt709), 3840x2160, SAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 1k tbc (default)