Nightbuild on Mecool KIII Pro

  • Hi,


    I tried to install LibreELEC-AMLGX.arm-10.0-nightly-20210305-05575a6-box.img.gz on Mecool KIII Pro, but no boot only black screen.

    I create SD Card with LibreELEC USB - SD creator with this image, then copy mecool kIII pro dvb file from dvb folder to sd card root, rename dvb file to dvb.img and it’s not working.


    Anybody to help me?


    Thanks

  • Make the SD card again, but this time a) set the dtb name to boot in uEnv.ini, b) do not move or rename the dtb file.

  • Clean boot, wait 30 seconds, then run "dmesg | paste" and share the URL generated. In theory the device-tree has WiFi enabled, but I've never seen the box and have no idea what WiFi chipset is used inside. The log can help.


    NB: I'm also interested to see what remote and IR keymap is used, as the current keymap named in the device-tree doesn't actually exist. If you share working IR codes I can add it.

  • I tried also with USB wifi stick wich one works very well on CoreElec 9.2.6., and create log files for:

    with USB wifi stick

    http://ix.io/2RU9

    without USB wifi stick

    http://ix.io/2RUf


    about second request: how to give you working IR codes, to copy it from coreelec or something else,

  • Code
    cd /storage/.update
    wget https://chewitt.libreelec.tv/testing/LibreELEC-AMLGX.arm-9.95.1.tar
    reboot

    ^ run those commands to update to an image which should (in theory) have the missing firmware for the WiFi card, and a revised device-tree file to enable BT support. If this works I can send the device-tree changes upstream to the Linux kernel.


    For the IR keymap, either identify the keymap file or name that CE are using or record the keycodes, see Infra-Red Remotes - LibreELEC.wiki (which is not that hard). Make sure you note the button press order to match the recorded codes. Most Amlogic remotes use the NEC protocol.

  • Can you share "dmesg | paste" from the KIII pro as I'd like to see if the BT is working now. If you also have a KII pro box (S905 or S905D?) it would be good to see the dmesg log from that too. Also, if you can share pics/photo's of the two remotes it would be appreciated. I like to reflect the physical device layout in the keymap code.

  • Keymaps on both RC are working well. These are log files:

    Mecool KIII Pro

    http://ix.io/2Sb2

    Mecool KII Pro

    http://ix.io/2Sb4


    Meccol KIII has small flickering problem jus before boot logo, see video:

    External Content vimeo.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Can you update firmware for mentioned usb wifi card (RTL8811AU). This card works better then internall in Mecool KIII Pro.

  • Amlogic sets lots of video stuff in u-boot that might not be handled cleanly when we start Linux; there's not much we can do about that and I don't have the u-boot sources for MeCool boards to replace it with modern u-boot. Experiments in that direction require you to have UART access to the board so we can see the early boot output from u-boot - and you need to have backups of the original firmware and know how to restore them in case things don't go to plan.


    LibreELEC-AMLGX.arm-9.95.1.tar now has the correct BT firmware name (last image had right file but wrong name).


    I'll have a look for the Realtek WiFi driver. If it's supported in-kernel I can add support. If it requires the out-of-tree vendor driver I'll pass because those break with each kernel version change and are a maintenance headache.

  • I'm also interested to know if the blue? LED on the boxes is working .. and if hitting the power button results in a power off (or suspend) type action?

  • Yes, it is working as usual. Blue one power on, and red one power off. Press the power button device will do power off.

    It same on both devices; KII Pro and KIII Pro.

  • Can you share dmesg from one of the boxes again - I want to confirm the BT firmware is loaded so I can get the changes merged.