Beelink Mini MXIII WIFI and BT

  • I downloaded your file and it looks OK... Do you even get the wireless option or not?... If you do, you must turn it off then on to get the SSID from the router... Also there was one time that it didn't work with me after turning on the box, so I had to reboot again to make it load wifi drivers...


    Sent from my GM 5 Plus d using Tapatalk

    Edited once, last by mytbyte ().

  • Okay I'll try it again. I did not get any wireless option come up at all. I have rebooted many times.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • I did not get any confirmation when I ran the following command via putty.


    chmod ugo+x /storage/.config/autostart.sh

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • No, I meant for you to execute "autostart.sh" via command "./autostart.sh" (without quotes) from inside .config directory

    Edited once, last by mytbyte ().

  • Code
    1. LibreELEC:~ # /storage/.config/
    2. -sh: /storage/.config/: Permission denied



    No, I meant for you to execute "autostart.sh" via command "./autostart.sh" (without quotes) from inside .config directory


    [hr]

    Code
    1. LibreELEC:~ # /storage/.config/
    2. -sh: /storage/.config/: Permission denied



    [hr]
    The last time I made some progress (not much) I was able to access the .config directory and run ./autostart.sh. here is the output.

    Code
    1. LibreELEC:/ # cd /storage/.config
    2. LibreELEC:~/.config # ./autostart.sh
    3. : No such file or directoryad module /lib/modules/qca9377-aml/compat.ko
    4. mount: mounting /lib/modules/qca9377-aml/cfg80211.ko on /lib/modules/3.14.29/ker failed: No such file or directory

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().

  • Code
    1. LibreELEC:~/.config # cd #
    2. LibreELEC:~ # cd .config
    3. LibreELEC:~/.config # ./autostart.sh
    4. : No such file or directoryad module /lib/modules/qca9377-aml/compat.ko
    5. mount: mounting /lib/modules/qca9377-aml/cfg80211.ko on /lib/modules/3.14.29/ker failed: No such file or directory



    [hr]

    [hr]
    I can see every file in file manager that the script talks about.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().

  • Yes, that was my ouptut as well before I did the "chmod ugo+x /storage/.config/autostart.sh" command

    Edited once, last by mytbyte ().

  • Here's my output. What am I supposed to do now??

    Code
    1. LibreELEC (community) Version: 7.0.2.009
    2. LibreELEC:~ # cd #
    3. LibreELEC:~ # cd .config
    4. LibreELEC:~/.config # ./autostart.sh
    5. : No such file or directoryad module /lib/modules/qca9377-aml/compat.ko
    6. mount: mounting /lib/modules/qca9377-aml/cfg80211.ko on /lib/modules/3.14.29/ker failed: No such file or directory
    7. LibreELEC:~/.config # chmod ugo+x ./autostart.sh
    8. LibreELEC:~/.config # chmod ugo+x /storage/.config/autostart.sh
    9. LibreELEC:~/.config #




    Yes, that was my ouptut as well before I did the "chmod ugo+x /storage/.config/autostart.sh" command

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • do the command again...try from inside .config directory, try ommitting the path /storage/.config


    after that do "ls -l autostart.sh" and report output here

    Edited once, last by mytbyte ().

  • Code
    1. LibreELEC (community) Version: 7.0.2.009
    2. LibreELEC:~ # cd #
    3. LibreELEC:~ # cd .config
    4. LibreELEC:~/.config # ./autostart.sh
    5. : No such file or directoryad module /lib/modules/qca9377-aml/compat.ko
    6. mount: mounting /lib/modules/qca9377-aml/cfg80211.ko on /lib/modules/3.14.29/ker failed: No such file or directory
    7. LibreELEC:~/.config # chmod ugo+x ./autostart.sh
    8. LibreELEC:~/.config # ls -l autostart.sh
    9. -rwxr-xr-x    1 root     root           257 Nov 13 03:03 autostart.sh
    10. LibreELEC:~/.config #



    do the command again...try from inside .config directory, try ommitting the path /storage/.config


    after that do "ls -l autostart.sh" and report output here

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • yeah, sorry, you must do ./autostart.sh again, after ugo+x command


    it's perhaps best if you reboot

    Edited once, last by mytbyte ().

  • here's my output



    yeah, sorry, you must do ./autostart.sh again, after ugo+x command


    it's perhaps best if you reboot

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • Still just the wired connection shows up in LIbreELEC settings under Connections.


    What now?

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • I have tried it now I seem to get a different error:

    Code
    1. LibreELEC:~ # cd #
    2. LibreELEC:~ # cd .config
    3. LibreELEC:~/.config # ./autostart.sh
    4. insmod: ERROR: could not insert module /lib/modules/qca9377-aml/compat.ko: File exists
    5. LibreELEC:~/.config # chmod ugo+x ./autostart.sh
    6. LibreELEC:~/.config # ls -l autostart.sh
    7. -rwxr-xr-x    1 root     root           256 Nov 16 21:17 autostart.sh
    8. LibreELEC:~/.config # reboot

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().