AverMedia TD310 not recognised with LibreElec 9.2.6 / tvheadend 4.2.

  • Hi,


    Trying to expand Kodi to take care of TV, I picked up an AverMedia TD310.


    AVerMedia - LinuxTVWiki

    AVerTV TD310 - LinuxTVWiki


    Shows up in Linux dmesg output ok:



    and from lsusb -v ..


    But in "tvheadend", under "DVB Inputs", the "TV adapters" panel has the "TV adpaters" folder icon with nothing under it.


    Is there a magic piece of glue that I'm missing?


    With tvheadend logging enabled:


    for whatever reason, frontend0 doesn't get detected even though it is there:


    Edited once, last by relictv ().

  • okay, this was my fault.


    I was too enthusiastic about PVR things in Kodi.


    I had "VDR PVR Backend" installed and enabled in Kodi too. It got the dvb device before tvheadend.


    How did I discover that? From ssh logi:


    LibreELEC:~ # lsof |grep dvb

    927 /storage/.kodi/addons/service.multimedia.vdr-addon/bin/vdr.bin /dev/dvb/adapter0/frontend0

  • Hi,


    I would like to run AverMedia TD310 on Raspberry Pi 3. I have installed latest LibreELEC, but TV tuner is not recognized by Tvheadend Server 4.2.


    Based on this link I conclude that AverMedia TD310 should by supported under Linux.


    I am not familiar with Linux (but otherwise I am computer literate). As LibreELEC beginner I have few questions:

    Q1/ It should be install some extra drivers to make Aver TD310 wokring under LibreELEC or should be working with standard LibreELEC drivers?


    There are three LibreELEC driver modules A) LE default driver, B) DVBdrivers for TBD and C) DVB drivers from the last kernel

    Q2/ Which one (or anyone?) is suitable for Aver TD310?


    If some extra drivers are needed...

    Q3/ Where can I find it and how can I install it?


    I tried LibreELEC version 9.0.2 and 9.2.6 (RPi2.arm) with same result - TV tuner was not recognized by Tvheadend Server 4.2.

    I tried follow this guide to install AVerMedia TD310 on Ubuntu 20.04 - without success (log/output is in attachment, but I do not understand it).


    Can somebody gime me advice (step by step) how to make it working?


    Thank you for help

  • You don't need linux. Install Libreelec. then add tvhead addons. Search under addons for tvh. You should find the server & client. Install them. For the server, you need to configure it, add the ip address, of the Pi, then give it a logon name & password.

    Then from a web browser type in ipaddress with the port number 9981. 192.168.0.xx:9981


    this should open the wizard.


    Under configuration TV adapters you should see a folder open it, IF you can see a file you have the correct driver, if not, then going back to Libreelec try a different DVB module. I think these are found under programs.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass

    :)

  • @bubblegum57 Thank you for response.


    I did exactly all what you described... - under configuration TV Adapters I can see a folder, but there is no file (with DVB T2 tuner) inside. So I was going back to LibreELEC Module Drivers and tried gradually all the three modules A/, B/ and C/ (with reboot meantime) - without success - no DVB tuner was appear under TVheadend -> DVB Inputs -> TV Adapters.


    So my questions are...

    1/ Is AverMedia TD310 supported by the latest LibreELEC or I do something wrong?

    2/ If not, is there is any way how to make AverMedia TD310 working under LibreELEC - install some extra drivers?

    --> people say Yes it is working under Linux (now, not in past) and CoreELEC is based on Linux, am I right?


    Thank you

  • 1. ?

    2. Libreelec is based on linux, perhaps someone can create drivers for it.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass

    :)

  • Hi again,


    my AverMedia TD310 is working under LibreELEC now. Where was the problem I do not know......


    1/ I started from begin (with new LibreELEC image) again (three times without succes before!)....

    2/ I have used B) DVB drivers for TBD

    3/ I have installed VDR PVR backend (insted of the TVheadend Server)

    --> and voila - DVB-T tuner was found :)

    4/ I have tried switch to TVheadend

    --> and voila again - DVB-T tuner was also found and TV channels were tuned succesfully !!!


    The things are going strange sometimes...