LibreELEC display rolled around by one pixel

  • Sorry if this is actually already posted somewhere but I was unable to find anything about it. I installed LibreELEC 9.80 nightly 20201225 for use with a Raspberry Pi 400 and a BenQ PD2700Q monitor. LibreELEC booted up using a 1920✕1080 resolution even though the monitor's native resolution is 2560✕1440. I chose to leave it because it will probably perform better, and it looks quite all right.


    There is, however, one little snag: the display is rolled over to the right with the right-most pixel or two showing on the left side of the screen instead. Any ideas on how to fix it?

  • RPi4/400 video driver currently supports 1920x1080 max, support for higher resolutions isn't fully implemented yet.


    The pixel-wrap is a known issue in the video driver, see here vc4-kms-v3d-pi4 offscreen quad leaks to the left side of the screen buffer · Issue #3667 · raspberrypi/linux · GitHub and here [BUG] Final output image overflows by 1 pixel to the right, pixels wrap around to the left of the screen · Issue #4779 · LibreELEC/LibreELEC.tv · GitHub


    ATM we're waiting for fixes for these issues, when they are included in the RPi kernel/video driver we'll add them to LE as well.


    so long,


    Hias

  • Sorry if this is actually already posted somewhere but I was unable to find anything about it. I installed LibreELEC 9.80 nightly 20201225 for use with a Raspberry Pi 400 and a BenQ PD2700Q monitor. LibreELEC booted up using a 1920✕1080 resolution even though the monitor's native resolution is 2560✕1440. I chose to leave it because it will probably perform better, and it looks quite all right.


    There is, however, one little snag: the display is rolled over to the right with the right-most pixel or two showing on the left side of the screen instead. Any ideas on how to fix it?

    A workaround is to use screen calibration to modify the size of the screen slightly.

    Go to Settings > System > Display > Video calibration... and use the cursor keys on your keyboard or remote to set the overscan compensation for both top-left and bottom right to (1,1). Unfortunately you have to set the screen size separately for each refresh rate you use (23.98, 50, 60 etc.) I only ever watch 23.98 and 50fps so I just set it for those and leave the rest. To do that, change the refresh rate (Display > Refresh rate) and then go back into Screen Calibration.

  • Thanks HiassofT and Halloway, I have now also seen the issue under RPiOS at maximum resolution. I gather we'll have to wait until it gets fixed in the kernel.