MyGica T230A

  • /dar de ombros

    the dmesg log did not help?

    Need another document?

    I realized that different from the tbs5520se The same was needed:

    Add CONFIG_DVB_USB_TBS5520SE=m to projects/Amlogic/linux/linux.aarch64.conf

    It will look like this:




    It is useless knowledge if not shared the world.

  • Looks like the file got corrupted somehow.

    Try this one.

    The other times only one line entered:

    patching file include/media/dvb-usb-ids.h

    Now it was different, there were two

    smp :idea:

    Oops! Now you recognized it, at first! The Search is still testing, some frequencies I had to redo a few times to find the channels.


  • Code
    [   13.312097] si2168 11-0064: downloading firmware from file 'dvb-demod-si2168-d60-01.fw'
    [   13.639898] si2168 11-0064: firmware version: D 6.0.13
    [   13.644624] si2157 12-0060: found a 'Silicon Labs Si2141-A10'
    [   13.645827] si2157 12-0060: downloading firmware from file 'dvb-tuner-si2141-a10-01.fw'
    [   13.810937] si2157 12-0060: firmware version: 1.1.11

    Generally, new firmware is needed

  • I tried to dump firmware which loads in Windows and its same file as dvb-tuner-si2141-a10-01.fw but in case Si2168 there loads only small part of file but when I tried to load this file it's shows me error when downloading firmware EINVAL 22 /* Invalid argument */ or EREMOTEIO 121 /* Remote I/O error */ so is any way how to get proper firmware? I tried to add another hex commands to set chip flags like in Windows but result are same and nothing changed.

  • Sorry I am little confused from this type of programing. I am doing with drivers first time. :) Can you describe which role have firmware or can you send me link? I only know that when I connect and want to tune some frequency a firmwares are sended to device. So I think that dvb-demod-si2168-d60-01.fw is not good for this device or am I wrong? I have very bad reception compared to RTL-SDR (RTL2832u chip).

  • Okay so sorry for my mistake of meaning about firmware. I found mistake somewhere in my DVB-T antenna (yagi antenna on roof) connection. I don't know why I have low signal when I connected coax cable directly from antenna power amplifier to tuner. But when I connect between them one "T" splitter and to other end of splitter connect included antenna from tuner package then signal is full. But at the end, tuner is working very well now.

  • Hello,

    I have the same problem. Is there a chance to see this patch integrated into the LE official driver?

    I don't know how to compile my version myself.

    Thank you.

  • Hi
    Can you help how to start I'm lost.

    My setup:

    RPI4, LibreELEC 9.2.6

    MyGica T230A

    I would like to use the TV stick with the RPI4 running LibreELEC.

    Which files driver/firmware should I download

    Where and how should install/copy/sftp/extract...

    Thanks in advance