Raspberry PI 4 Model B 4GB RAM: LibreELEC (Leia) 9.2.6 Only HDMI sound disappeared after updating

  • Dear Readers,


    Today, on November 20, 2020, I downloaded two files from the website LibreELEC Downloads – LibreELEC.

    LibreELEC.USB-SD.Creator.Linux-64bit.bin and LibreELEC-RPi4.arm-9.2.6.img.gz

    I set up YouTube and NetFlix without any problem.


    Unfortunately, the sound on the HDMI cable has stopped working.

    I turned on the clicking noises, which I also can't hear.

    In the file called: 2EO7.txt I included a log of my hardware.


    All hardware is the same, only the newer software.

    The sound works analog (headphone jack) and Bluetooth.


    In the same way, I have previously uploaded LibreELEC (Leia) 9.2.5 without any problems on the same medium.


    I don't know the PI platform and I would like to ask for help for a beginner, how should I solve the problem?


    Best wishes,

    Marek

  • Dear Readers,


    Raspberry suggested to enter in one line: snd_bcm2835.enable_headphones = 1 snd_bcm2835.enable_hdmi = 1 snd_bcm2835.enable_compat_alsa = 0. Unfortunately, there is still no sound via HDMI.


    I put in the original medium with the Rassberry PI 4B 4GB system, which previously had sound in HDMI.

    Currently not working, before and after updating this media.


    I considered that maybe the fragile mini HDMI:0 jack is broken.

    When mounting on HDMI:0 I had video and audio, and on HDMI:1 only video (no audio).

    In the documentation I can't find the command to switch audio from HDMI:0 to HDMI:1.


    I don't know what to do because I can't interpret the error series from 2Fe1.txt.


    I kindly ask for help,

    Marek

  • Well, I am using RPi4 and had no HDMI sound issue after upgrading LE to 9.2.6.

    I don't think the onboard micro HDMI connector is broken, more likely it could be a cheap cable with bad contacts. But usually if there's a video OK, the audio also works ( AFAIK both goes through TMDS channels ).

    At first I would check the TV / display attached if the audio is not muted / switched off there... Or if there are external speakers connected to display...

    AFAIK the secondary HDMI port on RPI4 is not supported in LE. So far I did not have a reason to play with the settings (using just the HDMI 0 port) so I don't know what is possible to do...

    Just quickly tested the tvservice command which partially works on LE 9.2.6 with issues (sometimes the -v parameter is ignored, sometimes it hangs etc.) on 2 HDMI displays connected and sometimes I was able to switch video to secondary HDMI port (using -p and -o parameters on both ports but don't ask me how exactly, it's hard to reproduce it). But just the video.without sound and without LE GUI.

    There's -a parameter which should display info about audio supported so maybe you can try to play with this.

    LE:~ # tvservice -l

    2 attached device(s), display ID's are :

    Display Number 2, type HDMI 0

    Display Number 7, type HDMI 1

    LE:~ # tvservice -a -v7

    PCM supported: Max channels: 2, Max samplerate: 192kHz, Max samplesize 16 bits.

    AC3 supported: Max channels: 6, Max samplerate: 48kHz, Max rate 2040 kb/s.

    LE:~ # tvservice -a -v2

    PCM supported: Max channels: 2, Max samplerate: 48kHz, Max samplesize 24 bits.


    LE:~ # tvservice -s -v2

    state 0xa [HDMI CUSTOM RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

    LE:~ # tvservice -s -v7

    state 0xa [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

    LE:~ #

  • If you connect a display only to HDMI 1 port and upgrade to LE 9.80 nightly, Kodi will work - both audio and video goes to HDMI 1 automatically. When 2 monitors are connected, on both HDMI 0 and HDMI 1, Kodi works on HDMI 0 only.


    So it should be yet possible to switch between HDMI 0 and HDMI 1 but I don't know what to configure. In Kodi / Settings / System / Display the option Monitor is missing even though I tried to play with the ~/.kodi/userdata/guisettings.xml modification, so far I failed to get the Kodi working with preferred HDMI port when both HDMI ports are occupied.


    Also tried to modify the /flash/config.txt in accordance with this post Rpi4 - switching between different resolution HDMI outputs with one click but so far not succesfully.

    Edited once, last by ghtester ().