Pixel ratio does not save after reboot

  • Hello everyone ,

    Here I have a problem when I change my pixel ratio from the interface and I restart my raspberry pi 4 the ratio is not saved.


    So I created an advancedsettings.xml file and I still have the same problem ..:(


    The guisettings.xml file is rewritten on each restart.

    How can I block the overwrite of this file?


    If someone can help me ;( Thank you in advance

  • Probably your connected hardware (AVR / TV) is the problem. You can enforce an HDMI mode at config.txt. Read here about editing.

    Nop don't work for me ||..

    Do you have an other idea ?

    A little more detail on my config :


    I use Raspberry pi 4 with LibreELEC 9.2.5


    My config.txt : (my screen is a display for SLA 3d printer)



    Code
    hdmi_force_hotplug=1
    hdmi_drive=1
    hdmi_force_mode=1
    hdmi_ignore_edid=0xa5000080
    hdmi_cvt=1280 2400 50 5 0 0 0
    hdmi_group=2
    hdmi_mode=87


    I create also a advancedsettings.xml :


    Another big thank you for your lights

    Edited once, last by Delta ().

  • Yes, something like that works for many users with the same issue:

    Code
    hdmi_force_hotplug=1
    hdmi_ignore_edid=0xa5000080
    hdmi_group=1
    hdmi_mode=16

    Configure hdmi_group and hdmi_mode parameters as described at my above link.


    PS: If you use hdmi_cvt instead, then hdmi_group and hdmi_mode are not needed.

    Flexin' vinyl, jammin' break beats. 8)

  • Yes, something like that works for many users with the same issue:

    Code
    hdmi_force_hotplug=1
    hdmi_ignore_edid=0xa5000080
    hdmi_group=1
    hdmi_mode=16

    Configure hdmi_group and hdmi_mode parameters as described at my above link.


    PS: If you use hdmi_cvt instead, then hdmi_group and hdmi_mode are not needed.

    Hi my screen is not a TV and don't accept CEA is DMT :cry:
    and its resolution is 2400 x 1280 , that's why I use hdmi_cvt

    But i don't inderstand why in GUI video calibration overscan top and bottom are saved but not the pixelratio ..

    It is possible to not rewrite guisetting.xml ? or maybe create a script for use <pixelratio>3.000000</pixelratio> ?

    thanks a lot , I despair

  • Are you sure <pixelratio> belongs to advancedsettings.xml? I can't find that parameter at the docs.


    The Kodi doc says about video calibration:

    Note: Always adjust the TV display settings first. Most issues are due to overscan and similar settings being enabled on the TV/monitor. Trying to adjust this setting in Kodi while these settings on the TV are enabled will have you running in circles and never being able to fix the issue.

    So I think your issue is related to overscan settings. Read about overscan settings at config.txt (disable_overscan, overscan_scale etc.).

    Flexin' vinyl, jammin' break beats. 8)

  • Are you sure <pixelratio> belongs to advancedsettings.xml? I can't find that parameter at the docs.


    The Kodi doc says about video calibration:

    So I think your issue is related to overscan settings. Read about overscan settings at config.txt (disable_overscan, overscan_scale etc.).

    Yes you're right I can't find the pixelratio parameter for the advancedsettings.xml :(


    Thank you for this link and this idea around the overscan I will continue to search


    Unfortunately on my screen I have no parameter that I can modify


    What kills me is that : on an RPI3 with osmc kodi records the pixelratio but indeed it is not the same resolution (1080p) and not the same screen

    I used to have on an RPI4 because the RPI3 does not accept the resolution of this new screen


    I will try to fix as much information as possible with the advancedsettings.xml

    and also on the config.txt


    If I still have no success then I would try to install kodi from Raspian to see if it saves


    See you soon, and thank you again
    (sory for my bad english -> google translate  :S)