Changed to 5GHZ network and now mounts are broken.

  • Hi Everyone


    I have a Raspberry Pi 4 that i'm using as a media extender from a windows PC.


    I set up the mount shares fine on ethernet cable, i made all the config files and i was able to share my library and play it correctly.

    I moved to a new house, unfortunately everything here is wifi. I got both computers connected to 2.4ghz wifi and the shares still worked fine, i was able to connect and play meida

    I want to get both the windows PC and the Pi on 5ghz so i can stream x265, but libreelec did not see the 5ghz network (even though it showed up in raspbian fine).

    After some digging i was discovered the fix was to change my wifi region on libreelec over ssh, i'm in australia yet for some reason AU as a country code didn't help. The instructions recommended trying GB, so I tried that and it worked! i could see and connect to the 5ghz!


    As soon as i connected, every time i restarted i get an error saying mounting of all my shares failed (see first image). It asks me to look at the systemctl status in ssh for more details, but that does not reveal much (see second image). Going back to 2.4Ghz does not help either, the mounts are still broken.


    Nothing in the config mount files have changed (see image) and the windows pc media centre (which the mount files point too) has a permanent MAC reservation in the router that sets it to 192.168.0.191, the ip has not changed


    Any idea why these mounts have now broken? I don't really know where to turn to next.


    Any help would be greatly appreciated, thanks!


    edit/

    Should also mention i can ping fine between both machines and also i can access the raspberry pi folder structure through windows explorer. However i cannot access the windows pc through libreelec

  • Worked on it a bit more this morning.

    Its very strange, sometimes it can ping the windows box and other times it cannot. It can always ping the gateway, which makes me think theres some kind of blockage there. There is no internal firewall active or anything like that. Either way, whether it can ping the windows box or not it still won't mount.


    I've opened ports 111, 2049, 4001, 4002, 4003, and 4004 both UDP and TCP on the windows firewall just for luck, either way, disabling the firewall completely doesn't help


    Today instead of the "no route to host" error in the systemctl status i'm getting "Operation now in progress" see attached.


    Anybody?


    Edit/ Tried running a 30m network cable from the router to the pi, mount still fails with the same "Operation now in progress" message in the status. This leads me to think its not the wireless network adapter in the pi.

    Images

    Edited 3 times, last by steakeen: Edit/ Just in case anyone else has this issue i did two things. I reimaged by drive and the mounts still didn't work. Then i noticed i still could not ping the windows media centre downstairs, even through i could ping other windows machines fine. So i turned off the windows firewall and everything seemed to work again Despite be trying that on the previous buid. So who knows, now i just have to work out how to let the mount through the firewall, but at least i know where the problem is ().