Pi 3b+ and PoE hat not respecting fan temp settings in config.txt

  • Don't think its just me having tried this on a second Pi...


    I just upgraded a couple of my PoE powered Pi 3b+'s already fitted with PoE hats to 9.2.3. Everything seems to work as expected with the following exception...


    The Pi appears to ignore the

    Code
    1. dtparam=poe_fan_temp0=65000,poe_fan_temp0_hyst=5000,poe_fan_temp1=67000,poe_fan_temp1_hyst=2000

    entry in config.txt. the fans are still firing off at 50° not the 65° specified.


    My previous LibreELEC release (9.2.1) worked exactly as expected with the fan cutting in at 65°


    Any Ideas?


    Thanks

  • OK, tried that...


    config.txt now reads:


    dtoverlay=rpi-poe

    dtparam=poe_fan_temp0=65000,poe_fan_temp0_hyst=5000

    dtparam=poe_fan_temp1=67000,poe_fan_temp1_hyst=2000


    Fan is still kicking off at 50°


    Kernel is 4.19.122 which should be ok according to Reduce noise from rpi poe hat fan by Learath · Pull Request #3493 · raspberrypi/linux · GitHub


    Can't spot any typos and tried updating rpi-poe.dtbo for good measure, so have no idea whats happening here...

  • I think I now know what's going on, you probably have to override 4 trip points instead of two.


    There were two cooling zones added before the previously existing ones at slower fan rotation speeds.


    So try adding temp2 and temp3 as well, like in the github discussion, I guess that should work.


    so long,


    Hias