Borderless Kodi Window

  • Hello everyone!


    I'm using LibreElec 9.2.1 on a Raspberry Pi 3, Kodi version 18.6 . There's this "barrier" app that allows remote computers share one computer's mouse and keyboard. After a couple of days of sweating, cursing, and satanic rituals, I managed to get the app running in an ubuntu Docker image that rocks an Xorg server as the app needs a display to run.


    So it's pretty cool this far. I had to stop Kodi to be able to test the app, and it worked wonders. But when Kodi starts, even though I'm sure the app runs in the background, in the container, the Kodi window limits the cursor to only the screen the RPI is physically connected to. I can close Kodi and then everything is working again.


    Minimizing the window with "\" does not change anything. I've been looking through the Kodi GUI settings a bit, but I doubt there's anything there that will help me. I also looked a bit in the /storage/.kodi/userdata and found guisettings.xml (also read about advancedsettings.xml). For instance, I created and added this in /storage/.kodi/userdata/advancedsettings.xml:

    Code
    1. <fullscreen>false</fullscreen>


    But to no avail... I'll try tomorrow to browse some more through the guisettings.xml file and see if there are any other settings I might change, but I was wondering if someone actually knew of a way to achieve this. I mainly would like the mouse cursor to not be trapped inside the Kodi window. I'm guessing there's also some sort of GUI auto-focus on the actual window, as you wouldn't generally have any other GUI running in LibreElec.


    Any help would be much appreciated!

  • Any ideas on how to change this behavior?


    I also looked a bit into /storage/.kodi/userdata/guisettings.xml and set

    Code
    1. <setting id="videoscreen.fakefullscreen">false</setting>
    2. <setting id="videoscreen.screenmode">WINDOW</setting>



    I also tried


    Code
    1. <setting id="videoscreen.limitgui" default="false"></setting>

    But it always gets reverted to:

    Code
    1. <setting id="videoscreen.limitgui" default="true">0</setting>

    I also made all these changes in /storage/.kodi/userdata/advancedsettings.xml as well, as I've read this takes priority... Still nothing.

    Edited once, last by bobozaur: UPDATE ().