Raspberry Pi 4 build with X11 enabled

  • Hi!


    I'm trying to cross-compile a RPi4 version of LibreElec with x11 support (I'd like to be able to use xrandr and other X related stuff for a project I'm working on). I don't know if that's the right approach, but I changed the build options to include x11 by setting DISPLAYSERVER="x11".


    The build was going along nicely until it tried building libxkbcommon and failed. I tried with 9.2.2 and 9.2.1 tags so far, doing a full clean inbetween. Here is the build log output for libxkbcommon:


    I've done a quick search for the error but could not find useful info as of yet.


    I'm open to ideas, an especially if what I'm doing if possible or if I did it wrong!


    Thanks!

  • I have no recollection of anyone on staff or userbase ever atttempting to build Xorg stuff for RPi using our build-system. You will likely run into compile options that are hard-coded to assume x86_64 and missing X11 drivers for the Pi hardware. There is also a high chance that LE drops X11 completely in the near future so the longegivity of whatever you're trying to do might be questionable. You'd be better off with Raspbian.

  • LE doesn't need them or use them so I have no experience with them, so no opinion on them.