Install from repository option missing

  • I have quite fresh installation of LibreELEC 9.2.0/Kodi 18.5 on RPI 3B+. I was trying to install Netflix plugin from GitHub: GitHub - CastagnaIT-plugin.video.netflix- InputStream based Netflix plugin for Kodi


    I successfully downloaded repository.castagnait-1.0.1.zip, moved it to RPI and installed using "Install from zip file" option. Next step should be to install add-ons from alelec Kodi Repo but I cannot see option "Install from repository" at all!


    I'm quite new on this so maybe I'm missing soomething obvious. Can someone help me out of this, please?


  • Thanks for pointing me there, blueribb. According to the rules there I prepared kodi.log and just noticed a SQLite error saying "database disk image is malformed" - see the tail of the log fragment below. I believe this can be the cause of my troubles.


    I was wondering if there is any recovery tool available to fix such a thing?


    Thanks.


    UPDATE


    Finally, I found that it is quite easy to delete the malformed DB and have Kodi to recreate it and it works now! The culprit is apparently failing SD card, it needs to be replaced soon.


    Anyway, thank you for your support!

    Edited 2 times, last by Indy13: Update - problem solved! ().