RPi.GPIO installed but can't import over LE 9.2.0

  • Hi guys,


    Code
    1. LibreELEC:~ # python
    2. Python 2.7.16 (default, Nov 23 2019, 02:28:55)
    3. [GCC 8.3.0] on linux2
    4. Type "help", "copyright", "credits" or "license" for more information.
    5. >>> import RPi.GPIO
    6. Traceback (most recent call last):
    7. File "<stdin>", line 1, in <module>
    8. ImportError: No module named RPi.GPIO
    9. >>>

    Search in forum shows that people encountered the problem above resolved it with installing "Raspberry Pi Tools" add-on.

    Tried even download the latest tar.gz from RPi.GPIO · PyPI and install it manually => failed on missing compilers and dependencies...

    Tried to uninstall the "Raspberry Pi Tools" add-on and install it again.

    Tried to install "System tools" too... maybe dependecies... No luck.


    Running LE 9.2.0 + Kodi 18.5. Log.

    I noticed, when installing add-on, it reports on dependency of LE 9.1, not 9.2. Can be this a root cause of poor installation of RPi.GPIO?


    Is it possible to manage packages from command line(shell, bash)? How?

    I might try to install pigpio or RPIO...

    Edited once, last by grhhm ().

  • Sorry, I forgot to tell you the final tweak about "Raspberry Pi Tools"./shrug

    Import the GPIO lib like this at your Python script:

    Code
    1. import sys
    2. sys.path.append('/storage/.kodi/addons/virtual.rpi-tools/lib')
    3. import RPi.GPIO as GPIO

    Flexin' vinyl, jammin' break beats. 8)