Intel "Bay Trail" audio problem and fix

  • I have one of these smaller dual core Intel "Bay Trail" fanless computers that I have had issues with audio (cracking, popping) and the video skipping ahead without me wanting it to. I'm running on v9.2.1 but this has happened for years and I mainly just worked around the problem or tried to mitigate it by playing videos at a lower resolution than what my system should have been able to support.


    After extensive troubleshooting I found the biggest fix was to disable some of the specific Intel CPU features (see attached pic). I hope that others find this useful as this took me literally years to find.


    In my case I can now watch 1080p with good stereo audio and the only thing I've noticed is a little bit of slowness during the first 20 seconds of playing.


    No doubt this will impact more than just my system config, so feel free to try it. Just remember that if something goes wrong you can usually reset back to the default bios settings by powering down, removing the small battery on the board for 10 secs & then put everything back again.

  • Hello!


    Since Kodi 18.4 or 18.5 I also had a loud "popp" sound by starting anything music, videos, radio...

    To avoid this, I switched: settings>system>audio>keep audiodevice active to "always"


    Bay Trails still has problems with CState C6 and/or speedstep.

    (Bugzilla.Kernel.org Bug:10951)

    If your mainboard has "CPU C State Report" option it is enough to disable CState6


    GPU frequency is also affected, since Kernel 5.x (an intel driver bug AFAIK), which sometimes stays low and the video stutters.

    You can drop a line into Autostart.sh to keep GPU min freq up if your GPU is affected.

    Max. gpu frequency (xxx) eg 750mhz for HD500 700mhz for N3000 etc

    Code
    1. echo xxx > /sys/devices/pci0000:00/0000:00:02.0/drm/card0/gt_min_freq_mhz


    Regards

    Nicolas

    Edited 2 times, last by Nicolas ().

  • Yeah, I've tried the "keep audio device active" as well. I've literally tried any of the audio configurations available within expert mode and still got the same thing. This is quite specific to these Intel Chipsets and Realtek HD audio devices that are sometimes referred to as Azalia.


    Oh, sorry, forgot the other half. If you leave the BIOS as-is you will never get any devices recognized by ALSA so within the BIOS setting Chipset>South Bridge>Audio Controller set it to "disabled" (I know, a bit counter intuitive).


    After that Kodi will list the audio devices differently because they'll be recognized by ALSA and show up with the "ALSA-" prefix in their name. No more popping or static.


    Also any places in the BIOS that reference "High Precision Timer" I have set disabled because HPET is not ideal for devices of this vintage that show video. Also generally disabled ACPI where I could. This system has a problem where it misses or repeats USB events and hpet was a contributor when I was running Ubuntu or Mint on it.


    I didn't have to edit Autostart.sh to get great audio & video, but I'll keep track of it and leverage that if I need to. Thanks for the input Nicolas.