forcing RP4 to boot in 1080P mode while connected to 4K monitor

  • my TV is UHD 4K and only connected to the RP4 as 3840x2160 /30p. I can't force it to 60P using the config.txt setting for some reason. So I wanted to force the RP4 to 1080P in config.txt since all my video content is 1080i or 720P mpeg2 OTA TV recordings.


    However, using the hdmi_group=1 and hdmi_mode=16 in config.txt are ignored.


    Any ideas?


    Jim A

  • It's probably easiest to configure it in Kodi: Settings->System->Display, set resolution to 1920x1080p and refresh rate to 60Hz.


    I'd also recommend changing the settings level to Expert and set up the whitelist to enable 1920x1080 60/59.94/50Hz (and probably also 1280x720 60/59.94/50 Hz, then Kodi can output 720p and let the TV scale up). Ah, and set Adjust display refresh rate in Settings->Player->Videos to Always or On start/stop.


    so long,


    Hias

  • I can get good results changing the Kodi resolution and refresh rate as you stated above. I'll play with the whitelist.

    I have not had much luck understanding and using the Player setting "Adjust display refresh rate" or "Sync playback to display"


    Is Adjust display refresh rate the only change in player settings you'd recommend??

  • Yes. IIRC Sync playback to display will break audio passthrough so just use Adjust display refresh rate. Kodi will then switch refreshrate and resolution (as configured in the whitelist) to match the video.


    BTW: if you set up the whitelist better don't enable the 25/29.97/30Hz modes as that'll cause issues with interlaced content (kodi doesn't detect interlaced right and then tries to use eg 30Hz for 60Hz interlaced...)


    so long,


    Hias

  • Thanks, I find that Adjust display refresh rate to "always" introduces occasional 1 second blank screens. Setting it to "on Start/stop" only has the blank screens between commercials and the program. Once a program is running, no blank screens.


    So with Adjust display refresh rate off and the whitelist set I seem to have a very good picture for my OTA TV content.


    I'll never understand audio passthrough. I have my RP4 HDMI cable going to a AV receiver that splits out my 5.1 audio then the video goes from the AV receiver to the TV via HDMI. The audio seems to work fine with or without the Audio passthrough set.


    What would you use in my setup for passthrough??

  • It doesn't matter much if you enable passthrough (so your AV receiver decodes the AC3/DTS signal) or disable passthrough and set the number of channels to 5.1 (then the RPi decodes the AC3/DTS signal).


    Passthrough can be useful for the high quality TrueHD/Atmos/... formats (which can't be decoded in software but might be supported by the AV receiver), but ATM the RPi4 doesn't support passtrhough of these formats (that should come some time in the future, though).


    so long,


    Hias