Kodi NFS playback issues 9.2

  • Hi Team,


    I've just recently upgraded my NUC from 9.1.501 to 9.2.0 and it appears that anytime video playback is attempted the interface freezes for an extended period of time and then displays a message suggesting the file is no longer available. During the long freeze the debug information in the top left of the screen also freezes.


    I can still login via ssh and issue commands, and I can force a restart via commandline, however this issue is persistent even after restarts, reboots etc.


    I attempted to try 9.1.502 also and the issue is present in that version too, I've had to rollback to 9.1.501 for this to work successfully.


    Given that I have other devices in my household too I figured I'll give it a go on other devices, RPi2 seems to exhibit the same issue.


    All of the devices are using a mysql backend for the database.


    Upon further investigation it looks like I cannot browse any of my sources which are all NFS shares with the following notation: nfs://HOSTNAME/SHARE/


    This seems to cause the long freeze and there's an issue I was able to find on the Kodi forums: Can't add NFS shares.


    What isn't clear to me if this is if this is a libnfs or rpcbind problem and secondly if it's the client or the server, by following the other threads and github issues and based on what I'm experiencing I think it's a client problem, mainly because I can roll back LibreELEC to 9.1.501 and successfully play items from my NFS shares.


    I've attached the kodi debug logs for both devices, happy to provide any additional details if it will help too.

    Files

    • kodi.nuc.log

      (401.7 kB, downloaded 146 times, last: )
    • kodi.rpi.log

      (88.69 kB, downloaded 84 times, last: )
  • Hi. Have a similar issues. However I can play some mkv files and not other. I either get the Fil not found or it's hangs on 0% cache.

    Setup is 2 x NUC with shared Maria DB on a Synology NAS. Never had any problems running 9.1.501. Using SMB for file access.


    Not sure how to get the log files.


    Thanks

    Louba

  • I either get the Fil not found or it's hangs on 0% cache.

    Setup is 2 x NUC with shared Maria DB on a Synology NAS

    NFS does fine for me.

    - LibreELEC 9.2.0 on x86-64 Generic

    - Ubuntu 16.04.6 as NFS file server + Ubuntu mate 18.04.3 on Raspberry Pi as NFS server


    Both servers show up while browsing for NFS sources in LibreELEC. NFS browsing in Kodi in Ubuntu doesn't work for me.

    So this time I think your Synology NAS is to blame.


    As far as SMB is concerned, I think this is broken Kodi-wide. I tried a WetekHUB with CoreELEC 9.2.1 for Kodi 18.5, and just about every video had buffering issues when connected to a (old) Synology NAS via SMB. When I connected the WetekHUB to my NFS servers and played the same movies, the buffering was gone.


    Earlier I tried filling up the thumbnail cache on the WetekHub by copying the thumbnails to it from my office (Ubuntu) computer via SMB. Even that went wrong as I encountered multiple timeouts. So something is quite crapped up in either the Linux kernel(s) or the Kodi internals as far as SMB is concerned.

  • Thanks Klojum.


    After change from SMB to NFS all seems to work as expected again, movies that used to hang can now be played. :)


    Thanks

    Louba

  • @Klojum/@DaVu: Following on from the conversation over at Can't add NFS shares..


    I've just revisited this and attempted to upgrade again and utilise the "add network location" option, this does not work the I experience the same freeze when attempting to add the location.

    I haven't tried system mounts but I suspect this will work, purely based on the fact that the machine in question is a PXE booted NUC and the /flash and /storage locations are both mounted.


    As this is a clear regression in 9.1.502 that is also still present in 9.2.0 what can I do to help debug this? At this stage I'm still stuck on 9.1.501 as this version does not exhibit problems.