Tinker Board RK3288 HDMI flicker only at 23.976 and 59.94Hz

  • I just upgraded my old Raspberry Pi 3 with a new Asus Tinker Board S. I have a problem with some refresh rates.

    Video example here (80MB file): tinkerboard-hdmi-flicker.mkv


    My hardware:

    Asus Tinker Board S, the official power source from RPi 3B+, 1.5m HDMI cable, Panasonic ST50 (plasma screen, 2013).

    Latest offcial LibreELEC


    It seems that refresh rates 23.976 and 59.94 Hz are not supported on Tinker Board?

    - 1920x1080p 60Hz = works

    - 1920x1080p 59.94Hz = flickers constantly

    - 1920x1080p 50Hz = works

    - 1920x1080p 24Hz = works

    - 1920x1080p 23.976Hz = blank screen 95% of the time, some very distorted image sometimes appears

    - 1280x720p = same as 1080p

    I tried:

    - changing power source = didn't help

    - changing HDMI cable = didn't help

    - changing HDMI mode (RGB / Ybr422 / Ybr444) = didn't help. Using 422, the flickering corrupts colors, not just the image.

    - change TV (a smaller Panasonic ST50) in another room = didn't help

    - reverse power plug, try other wall socket (ground loop?) = didn't help

    - put back RPi 3B+ = no problems with the same setup

    - other OS = Official Android for TB doesn't have these refresh rates available. Official Debian for TB - I don't know how to change the refresh rate.


    Is this problem known? I couldn't find anything about it. Any ideea what causes it?

    Thanks.

  • The Tinkerboard doesn't support fractional frequencies since it uses a soc that was released in 2014 that doesn't have the hardware support for it.

    You will only get 24, 25, 30, 50, 60hz playback support.

    You can try to use an advancedsettings xml file to force 23.976hz to 24hz or enable sync to display in Kodi/LibreELEC's settings.

    To use fractional frequencies, you need a RK3328 or RK3399 device.