RPi4b + libreelec + Flirc + Harmony + Kodi = remote doesn't work on Kodi

  • Hey gang,

    Brand new to the Raspberry Pi/libreelec/kodi world, I moved over this weekend from a decade using a Popcorn hour. Ooh, I love it so far. I have been trying to get my logitech harmony 610 (I believe) to work with kodi using the Flirc USB receiver, so far unsuccessful.


    It's my understanding this should be plug and play and pretty much work. however I am having problems. :(


    steps I performed:

    --I installed the Flirc software and updated the firmware.

    --installed Logitech Harmony v.7 (my remote is about 9-10 years old).

    --I was able to add Kodi as a device, though I'm not sure which model to use. I tried 1, Kodi, Flirc, XBMC and one of the ones that was suggested.


    Once the remote was updated, I gave it a shot.


    Pushing the on button for this activity, receiver and tv turn on and sets proper input. yet I can't get anything to work on Kodi.


    I tried the Flirc on USB 2 and 3, same thing.


    I ssh'ed into libreelec and lsusb shows the device "Bus 001 Device 005: ID 20a0:0006 Clay Logic " though on my linux desktop it returns "Bus 009 Device 013: ID 20a0:0006 Clay Logic flirc"


    Bus is normal, different ports.


    Any ideas on what I should look at? is there a setting in Kodi or libreelec I need to enable?


    any help is appreciated.

    --nixit