New UHD TV but no picture after Boot/Install

  • Hi everybody...


    first of all I want to thank all of you contributing and devoloping Libreelec :-)


    I actually have a very queer issue with my Gigabyte Brix BRi3-8130 with an Intel i3-8130U CPU, 8GB RAM and 250 M2 PCIE SSD. With my old Full HD TV (Panasonic Plasma) it worked everything out of the box using the actual BETA version (LibreELEC-Generic.x86_64-9.1.501.img.gz)... but now I got a brand new UHD 4K Samsung Q85 QLED TV and I can only see the Gigabyte Bootlogo and then the TV says "No Signal/Source"... I already tried to install with an USB stick, but the same, I can see the Boot Logo and then the boot prompt and instead of any output it looks like nothing is connected anymore...

    But Libreelec seems to be running, because I can access the machine with ssh, here you can see the boot up log: 2019-09-22 19:06:34.399 T:140199041910912 NOTICE: ----------------------------- - Pastebin.com


    After some research I found some tips to get more info about the issues and found "xrandr" which shows the following info after boot:

    The connected TV still shows no source... and I have tried different HDMI 2.0 cables, including a premium certified cable... all with the same result.


    From my point of view the system switches the display of during boot, regardless if installing or using the installed LibreELEC... this issue should be no problem with the TV, because I also tried a BluRay Player with the same HDMI Port and cable which does not have any issues displaying 4k UHD HDR movies...


    Does anyone has an idea how to resolve this issue and get a working LibreELEC in UHD 4K with 3840 x 2160 @ 60Hz...


    Thanks and best regards

    highball

    Edited once, last by highball ().

  • Hi, I just found an article with some info about "randr" and tried to call it with some parameters:


    xrandr

    xrandr --output DP2 --mode 3840x2160 --rate 60.00


    This call brings back the picture on the TV in the defined resolution... but the call only works after calling "xrandr" without parameters?!?! I am totally confused??? Any idea what to do next and fix my system?


    Thanks and best regards

    highball

  • Hi, thanks for your response and yes... it is actually connected to the HDMI port of the Brix, I do not have a miniDP to HDMI cable... and I also tried all input ports on the TV.

    I think the DP1 is the miniDP and DP2 the HDMI... I am still very confused 🤔

  • but the call only works after calling "xrandr" without parameters?!?!

    So if you put those two in the autostart.sh file in the .config folder, does the brix work okay?

  • This was also suggested in the thread I found, but I think this can only be a workaround... because I cannot install libreelec with this combination again... actually I have my old FulHD TV for new installations, but I do not want to keep it...