Updated to V9.0, MPEG-2 playback now extremely choppy.

  • My HTPC is a LIVA X2. Up until yesterday it worked perfectly. However, last night I upgraded the LibreELEC version to V9.0.2 and I began having serious video stuttering issues.


    I watched a Bluray direct rip no problem, then I tried to watch a DVD direct rip and it was hanging on several frames per second. I tried several files (including ones that I had watched before on that machine), and they all suffered from the same issue. I have tried changing many settings, but only two appear to have any effect:


    1. Setting MPEG-2 not to use hardware acceleration. Because of the low-powered CPU, the framerate becomes so choppy that it's hard to tell if the original issue is still present.
    2. Setting the de-interlacing method to "deinterlace". This is watchable, but it does still show the occasional held frame (particularly when there is a lot of motion).

    The above lead me to believe that this is a hardware acceleration issue, but beyond that I don't really know. I'd be perfectly happy to go back to the previous version (I believe I was on 8.2), but I really don't want to reinitialize my library.


    Thanks!

  • awiouy

    Approved the thread.
  • can you update to the lastest LE 9.1.002 (Beta`ish) ? maybe this fixes it already

    I will try this tonight. This time I am going to image the existing installation first in case I have issues.