RPi 4 No Video Audio Only

  • Hello,

    I am trying to play videos using a RPi 4 with LibreElec 9.2 (Kodi 18.3) and having an issue where any video played only has audio - just a black screen for video.

    I have tried many different videos, some h264, some h265. All videos played have the same issue.

    I tried changing the video render method (which is current set to Auto-detect), but the option is greyed out and I am unable to change it.

    Any ideas? I have attached a debug log where I try several videos. I have no issues playing these files with my old RPi 3B+ with Kodi 17.2 (I havent updated that system in awhile)

    Thanks in advance for any help you can provide.

    EDIT: After reading other posts, I came across a post where someone suggested switching inputs from HDMI2 to HDMI1 (port closest to power jack). This did resolve my issue.


    • KodiLog.zip

      (190.34 kB, downloaded 210 times, last: )

    Edited 2 times, last by Libreuser9231: Wanted to add disclaimer that this would be more appropriate in Bug reports ().