Black Video Playback on RPi 4

  • I just upgraded to the RPi4 from a RPi2B+ where I was previously using openelec to playback some mkv and avi files off of a samba share. The RPi4 is a clean install of the RPi4 version of libreelec (and I've attempted to re-image twice just in case) and doesn't have any kind of crazy settings or changes made to it. For whatever reason, video will NOT playback on the RPi4 where it used to play fine on the RPi2. Audio comes through nice and crisp, no hitches. Subtitles even show perfectly and time correctly, but the video is just blank. Doesn't matter the filetype, doesn't matter if it's in 480p, 720p or 1080p, I get zero playback visually. No errors displayed, the logs seem to indicate it thinks it's playing back fine, but no image is shown. The UI is working great and seems responsive enough. This is being done on a 4K tv, and I have tried to change the display resolution to 1080p60,1080p30 and even 720p60 but no matter what I do, all videos both local and over samba are displayed as completely black. I tried googling for some solutions but the only complaints I can see from anyone are over 4K playback, which I'm not even trying to do yet. As a final note, when I enable debugging/logging the display fps seems to be locked around 15fps for some reason (not sure if that's just a caveat of the debugging or not) and CPU usage never peaks above 40% or so and temps are under 45 degrees C. Any help or tips would be greatly appreciated.

    Edited once, last by Drathro: Looks like the RPi4 only play back video on the HDMI closest to the power I guess. Hopefully that's just a funny software quirk that will be ironed out with time. Oh well, hopefully this may help anyone else that runs into the same issue. ().

  • awiouy

    Approved the thread.
  • Hello

    Exactly the same happens to me, I am testing librelec on my Raspberry Pi 4b 4gb on a samsung 4k TV, all menus work perfect, I have tried several resolutions but it does not play the video, the sound does work but the image looks black screen.


    Could you solve it?


    Previously I had the sd raspbian and if it worked


    I hope you can help me, thank you very much in advance.:S

  • Read the very bottom of the original post above yours