RPi 4b/4gb - boots up and immediately freezes, can't do anything...

  • Hi all.

    I'm hoping someone could help me with this, just as the title states - I have a Pi 4 with 4gb. It boots up, I get libreelec logo, then the Kodi logo, then to the main menu and after about 1-2 secs it completely freezes. Top right corner (in the Kodi info box) it always freezes on [Connecting to: Pulse-Eight CEC adapter]. Not sure if that has something to do with it freezing or that's just how far it gets in the setup. So that's what happens. And below is what if done to try and get past the freezing...


    -heard about USB C problem so I've tried 3 different USB C cables

    -tried unplugging everything from the pi and booting with just [power] connected

    -tried booting with the TV off (I guess the thinking there was it wouldn't detect the HDMI-CEC)

    -tried 3 different sd cards

    -tried writing the image 3 different ways between 2 different image tools

    -in my TV settings turned off the CEC stuff (on my TV it's called EasyLink)

    -in TV settings changed the HDMI mode from [normal] to [legacy] (not sure what it does but it seems to like legacy better, on normal 1/2 the time I got no picture at all)

    -after being at a loss, I even added a fan & heatsink. I seriously doubt it's so hot after bootup it freezes instantly. But I didnt know what else to do.


    NOTHING MADE ANY SORT OF DIFFERENCE, IT FREEZES AFTER BOOTUP EVERYTIME!


    I can't get to a error log to see what's going on. As far as what I'm using... a brand new BlueRigger HDMI to mini HDMI cable connected to a 55inch Phillips TV and a Pixel 3 XL wall adapter and the Google USB-C to USB-C cable it came with (figured it was the highest quality power & cable I had). I would of assumed the Pi is just too new to have the bugs worked out if I didn't see accounts online and YouTube of everyone else's booting up and working just fine. I cannot figure out what I'm doing wrong! Any help or advice greatly appreciated. Thanks.

  • Do you have the original Pi 4 power adapter ? Even though the wall adapter you mention has similar ratings, it may be the problem. Only a guess.

  • No, I don't. I'll order it to eliminate "Power" as the problem. When it comes in, I'll report if it makes a difference in case anyone has a similar issue.

  • I have the exact same problem, tried different sd cards en I use the original rpi power adapter AND hdmi cable. Everything is brand new (except sdcard, wich is an samsung evo 32gb class 10 uhs 1) and did a clean install. I'm not new to libre elec or rpi, had it working on the pi3 but wanted to test the benefits of the pi 4 (4K).


    One time i've gotten trough the freeze but couldn't play anything, on reboot it freezed again :(


    I got myself the rpi with 2gb of ram.

  • At least I'm not alone... Does yours freeze at the same spot (connecting CEC)? I tried 3 different SD cards but coincidentally they were ALL the same brand which is also the same as yours (Samsung EVO 32gb class 10), I'm going to try a different brand just for kicks, I have a few SanDisks somewhere. If you figure anything out, please update. I'm stuck. I too had no problems running libreelec on RPi3b+ but the Pi4 is a NO-GO. I've been trying to get it working for 2-3 days now with ZERO progress. Later today I'm going to hook up to a proper monitor and see if it is something with the HDMI-CEC "handshaking" on my smart TV... Don't know what else to try. I ordered the "official" power supply just to eliminate that as an issue but I'm fairly certain the one I have is adequate.

  • Yes, my freezes at the same spot, hdmi cec. My other sd I tried was a sandisk but without result.

    I tried on my pc monitor and on my 2019 samsung smart tv without any luck. I will keep looking for solutions but so far I can't find any.

  • Yeah, I've tried both...


    *Edit- I actually didn't try both (properly) and this was in fact the issue. Note to self- must always use HDMI port closest to USB-C

    Edited once, last by Spectt84: I was wrong. The edit is to reflect the fix to help someone if they stumbled across this issue. ().

  • I really don't want to believe this.... but it worked for me (so far on my pc monitor) I really thought I tried both ports, but i didn't try it with the samsung sd-card, maybe that did the trick??


    I'm going to try (a bit ashamed haha) it on my regular TV.


    Sometimes the solution is so simple, you forget to try the most simple things...

  • Oh.. My.. Efffing.. God.. It works! I can't believe that. When I was trying that HDMI port yesterday is when I was also messing with the "HDMI mode" on my TV and it wasn't giving me any picture at all. After Stewie said that worked for him I went and tried it again and it loaded up perfectly! Thanks for the tip. I probably would of not tried that again because I was under the impression I already did. Awesome! 👍

  • I can't believe it either, I thought I tried both, I was thinking it was due to the new Flirc case, but when I tried it with no case I still had the problem and a simple Google search led me to this post. Thanks for saving me a headache, I registered just to post this thanks!!