LibreELEC + Retroarch 9.80 for Raspberry PI 4 !

  • Cael : I don't konw if MSU-1 is responsible of crashing :(

    miezbert : Cores can be found in /tmp/cores/


    You can use SSH to connect to libreelec and do the following :

    cp -R /tmp/cores/*.so /storage/pictures


    You will get all so in Pictures shared folder.

    Copy in your retroarch/cores folder

  • Hi there,

    thanks a lot for this release.

    I have a general question... no matter what I'm changing in settings with bilinear filtering there are always horizontal lines in movies/streams etc. Is it because there is no final adoption with the Pi 4 (4GB) yet or is it a problem with your release? With my old Pi3 there is no such problem. RetroPie runs for me so far...

  • Hi,


    I have no horizontal lines on my build with my 2gb rpi4

    If you are talking about kodi part, it still remains beta/alpha for the rpi4 at this stage.


    And i can not give support about it

    Only on retroarch part.

  • But i think it's strange, there is no horizontal line on my rpi. I use HDMI0 (hdmi near power supply connector)

  • learned how to compile an build (lord 50GB minimum HDD Image when done in a VM... F*!) i'll report if i see any changes in RetroArch behavior,

  • Hi there,

    thanks a lot for this release.

    I have a general question... no matter what I'm changing in settings with bilinear filtering there are always horizontal lines in movies/streams etc. Is it because there is no final adoption with the Pi 4 (4GB) yet or is it a problem with your release? With my old Pi3 there is no such problem. RetroPie runs for me so far...


    Hi i have the same problem too

    Bicubic seems to fix this horizontal lines

  • Hi, Thanks for the great work !!!


    Why the ROM Folder, that i delete are back when reboot?

    Can i change that?

  • Hello, thanks for this awesome initiative!

    Is it possible to start this from IAGL? All I get now when I try to set it up is the boot screen all over again, then nothing is loaded.. I guess it's something with the launch commands, but I'm not sure what to change them to.

    Thanks in advance!

  • Hi there,

    thanks a lot for this release.

    I have a general question... no matter what I'm changing in settings with bilinear filtering there are always horizontal lines in movies/streams etc. Is it because there is no final adoption with the Pi 4 (4GB) yet or is it a problem with your release? With my old Pi3 there is no such problem. RetroPie runs for me so far...

    Latest release 9.80_2 use a specific build of kodi for rpi4, no more tearing image (and no bilinear filtering)

  • Latest release 9.80_2 use a specific build of kodi for rpi4, no more tearing image (and no bilinear filtering)

    i havent updated to it yet, but on the 7 inch Waveshare Screen i didnt see any of that, maybe the original problem was on larger screens?

  • when you launch a video that use smaller resolution than your display can support, kodi use a filter to adjust image to the screen

    but bilinear filtering cause strange bars, tearing etc, other filters seems to be ok but slower.

    This kodi build is specific to rpi4


    GitHub - popcornmix/xbmc at leia_pi4

  • when you launch a video that use smaller resolution than your display can support, kodi use a filter to adjust image to the screen

    but bilinear filtering cause strange bars, tearing etc, other filters seems to be ok but slower.

    This kodi build is specific to rpi4


    GitHub - popcornmix/xbmc at leia_pi4

    i get it given that the 7inch waveshare has a oddball Resolution of 800x480, thats what hid the issue

  • i compiled your source for rockpi4. It boots normal and i can install addons and change settings. But after reboot i cant start the system. There are a lot of Numbers like in "Matrix" and nothing happens...