LibreELEC (Leia) 9.2 ALPHA1 with Raspberry Pi 4B Support

  • Hey,

    got actually an sound issue (disappear) if i change the resulution from 1920x1080 to 3840x2160. At 1920x1080 everything is working fine (video&sound), also the 4k video files in 25hz will be played in 16:9 with any issues - if i raise the output of an 4k file to original size - the movie will be centered and alot of the movie boarder is out of the sceen (resize via an calibrate is not possible).


    Also standard movies up to 1920 work fine with Hyperion, only if i start an 4k Video the output for Hyperion is getting green.


    Got an RP4i 4gb, thats connected to an Samsung UE75NU8009 - the TV is plugged into the first port (nearest to the USB-C). The same issue is if the RPi4 is connected via an Samsung BluRay Player and this one to the TV.


    Got anyone an Idea ?


    Thanks

    Edited once, last by ChosenOne ().

  • Hi,

    i solved the continuous restart (reboot) when no HDMI device is connected

    I enabled the hdmi hotplug as follows:


    1. make filesystem writeable

    -- Change read only file system

    mount -o remount,rw /flash


    2. modify config.txt

    vi /flash/config.txt

    <manually remove remark from line with hdmi_hotplug>

  • hi everyone!


    I brought myself yesterday rpi4 4gb, its replacement for my rpi3b+. I have chinese clone of hifiberry digi but has a IR on board also. Soo I made fresh install on new rpi4 and put a hat on it like it was on rpi3b+... make same changes in config.txt and there is no ALSA card on Kodi. If I put "dtparam=audio=on" then I have ALSA on board showing, but no hifiberry like on rpi3b+.


    Can anyone help me please, been awake till 5AM and still don't have sound through Toslink...


    Everything else in comparison to rpi3b+ is brutally faster, but I don't have my 5.1 audio out :(


    Thanks 🤗

  • Please post your config.txt and dmesg and the exact model info (eg link to vendor webpage) of your audio card. It's hard to help without having any details.


    Code
    1. paste /flash/config.txt
    2. dmesg | paste


    so long,


    Hias

  • If you remove

    dtparam=audio=on

    And add

    dtoverlay=hifiberry-digi

    Is it working better?

    yeah, try to before but its same...


    GitHub - kusticM/rpi: rpi files



    hat :


    https://www.fasttech.com/produ…ound-card-w-i2s-to-s-pdif



    thank you very much !

  • config.txt looks fine but according to dmesg communication with wm8804 fails:

    Code
    1. [ 7.844393] wm8804 1-003b: Failed to read device ID: -121
    2. [ 7.844554] wm8804: probe of 1-003b failed with error -121


    Are you sure the card isn't defective or plugged in wrong?


    I did a test with my justboom digi card (no config.txt changes required as it has a HAT eeprom onboard) on RPi4 running LE 9.1.002 and it worked just fine

    Code
    1. [ 9.267296] wm8804 1-003b: revision E
    2. [ 9.274108] snd-rpi-wm8804 soc:sound: wm8804-spdif <-> fe203000.i2s mapping ok


    so long,


    Hias


  • Solved !


    Thank you very much, now when I look at dmesg I see that... was thinking that code was missing didn't even try to reconnect hat, idiot.


    Thanks again, I learned something now 😊

  • CvH

    Closed the thread.